summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/hexxagon/files/hexxagon-1.0.2-glibc-2.31.patch11
-rw-r--r--games-board/hexxagon/hexxagon-1.0.2-r1.ebuild27
2 files changed, 26 insertions, 12 deletions
diff --git a/games-board/hexxagon/files/hexxagon-1.0.2-glibc-2.31.patch b/games-board/hexxagon/files/hexxagon-1.0.2-glibc-2.31.patch
new file mode 100644
index 000000000000..037228067c90
--- /dev/null
+++ b/games-board/hexxagon/files/hexxagon-1.0.2-glibc-2.31.patch
@@ -0,0 +1,11 @@
+glibc-2.31 removed timezone support and it conflicts with the re-declaration.
+https://bugs.gentoo.org/710712
+--- a/src/gui/microtime.h
++++ b/src/gui/microtime.h
+@@ -24,6 +24,4 @@
+ #include <time.h>
+
+-int gettimeofday(struct timeval *tv, struct timezone *tz);
+-int settimeofday(const struct timeval *tv , const struct timezone *tz);
+
+ class MicroTime
diff --git a/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild b/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
index 467bf1e50f50..6ec2c8059c34 100644
--- a/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
+++ b/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic
+EAPI=8
+
+inherit desktop toolchain-funcs
DESCRIPTION="Clone of the original DOS game"
HOMEPAGE="https://www.nesqi.se/"
@@ -11,23 +12,25 @@ SRC_URI="https://www.nesqi.se/download/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND="dev-cpp/glibmm:2
+RDEPEND="
+ dev-cpp/glibmm:2
dev-cpp/gtkmm:2.4
x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-src_prepare() {
- default
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc-2.31.patch
+)
- append-cxxflags -std=c++11
+src_compile() {
+ emake AR="$(tc-getAR)"
}
src_install() {
- emake DESTDIR="${D}" install
+ default
+
newicon images/board_N_2.xpm ${PN}.xpm
make_desktop_entry ${PN} Hexxagon
- dodoc README
}