summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nagios-check_linux_bonding/Manifest1
-rw-r--r--net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_linux_bonding/Manifest b/net-analyzer/nagios-check_linux_bonding/Manifest
index b57e8c706be7..154fb3e4f536 100644
--- a/net-analyzer/nagios-check_linux_bonding/Manifest
+++ b/net-analyzer/nagios-check_linux_bonding/Manifest
@@ -1 +1,2 @@
+DIST check_linux_bonding-1.4.gh.tar.gz 24921 BLAKE2B ef582184471e4ca9d4b9a1d5cdee481852f1f452806ca081e04e74b7b469109f3a5998708cdb7ee6d3ffa9240cdbf721f0cbf6b3f4be2c4cc62042fce6647ccd SHA512 e8195d012a3da53983acdb8ea54d87995541e4e303dce28683ca04b6a6f84826c37db42c295b7e121092482a49268f57355284b57bb77a2212c46b834dd57088
DIST check_linux_bonding-1.4.tar.gz 24670 BLAKE2B 6f136043fdcc74f677963ad4798ea18a8f813c3bf6cf1d00f6649d72dfc7d953c01a43bd3050758a8461f255ce3a9d3ddbdd1bcb29de316ea6438f20409ce699 SHA512 2b1e11007680accd8667ceb8710c7a7448766fd0c5aa3be60a34209f1b25892e7fecc46f9fc5e7cc0d4776f68cc17f8db8d8f2758695c82045a5832e8a4c7e81
diff --git a/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4-r1.ebuild b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4-r1.ebuild
new file mode 100644
index 000000000000..0dfb488a8078
--- /dev/null
+++ b/net-analyzer/nagios-check_linux_bonding/nagios-check_linux_bonding-1.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_COMMIT="fde23cba225870ceb1162d918a6307c608e654a5"
+MY_P="${P/nagios-/}"
+
+DESCRIPTION="Nagios plugin to monitor bonding status of network interfaces"
+HOMEPAGE="https://github.com/glynastill/check_linux_bonding-1.4"
+SRC_URI="https://github.com/glynastill/${MY_P}/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}-${EGIT_COMMIT}
+
+src_install() {
+ default
+
+ local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
+ dodir "${nagiosplugindir}"
+ exeinto ${nagiosplugindir}
+ doexe check_linux_bonding
+
+ dodoc CHANGES
+ doman man/check_linux_bonding.8
+}