summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/pycares-4.2.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index 1d5ead82fc9b..1b0cb3519b51 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1 +1,2 @@
DIST pycares-4.2.1.gh.tar.gz 43939 BLAKE2B 40f147189d5daf841a8165da86d881f1822763fbd050b040f11bd1f63a768dfbc71c78230d41331486cbc2354175b528f298dbb167ef7801e57b05b4a13c820d SHA512 b5462b58bf75a9ee39496209c8270bc9c07070d34d9c2f2a2eed4752ebf83392e256248dda06ec5934c235cb37636e55a21cff4181b0a03c3eff24fbf9297eb4
+DIST pycares-4.2.2.gh.tar.gz 44200 BLAKE2B a857f20f0f1cf0243f02d7f8663bfba3d0f97f033afb5eee5ec3ff74b70279cb3535c04953c3131771a1a6447032e309dbed064a4e85b30980361f5db3d674f1 SHA512 1a6b30e8f55d37ca0af9dfd70fd3a0630b691f5f76b4f650e9c98c585b26bd1ff9c237fc1705ce5dc257857db0dce2f020f12099f0c211f5ad0f12196f39433b
diff --git a/dev-python/pycares/pycares-4.2.2.ebuild b/dev-python/pycares/pycares-4.2.2.ebuild
new file mode 100644
index 000000000000..aa636a8ce629
--- /dev/null
+++ b/dev-python/pycares/pycares-4.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="
+ https://github.com/saghul/pycares/
+ https://pypi.org/project/pycares/
+"
+SRC_URI="
+ https://github.com/saghul/pycares/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/pycares-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ net-dns/c-ares:=
+"
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}
+"
+BDEPEND+="
+ test? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+
+export PYCARES_USE_SYSTEM_LIB=1
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die "Tests failed with ${EPYTHON}"
+}