summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mate-base/libmatekbd/Manifest1
-rw-r--r--mate-base/libmatekbd/libmatekbd-1.28.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/mate-base/libmatekbd/Manifest b/mate-base/libmatekbd/Manifest
index 70557779379d..874ad2399bc7 100644
--- a/mate-base/libmatekbd/Manifest
+++ b/mate-base/libmatekbd/Manifest
@@ -1 +1,2 @@
DIST libmatekbd-1.26.1.tar.xz 460100 BLAKE2B 8fffa9630dabd00b74c243b928c65cc61c203297b2d96535f51fb8773b0a839fe596eb250f66d3a73a3085fb9d3c4946dbb1f23cec71214e84d9c570814202be SHA512 bf522d89cf32aea34ecc0e6df6b8cdedf6018b4e3abd935b5f32926b8b546bb85fcf4d2d3dcc1ec16bda38cd2bc69df16b39dd42b7ce32069cb34f682fdc38fd
+DIST libmatekbd-1.28.0.tar.xz 461700 BLAKE2B 297559c75fec4d283a7c06a0bfa3d2c7a90f84f42b70970c2b5e4a533bba1ce411bae258871088a77c55eaa29045802dcba114c8966a24afb7cd1c46fdca1f66 SHA512 303d75e8c082e4af5a031ede8a94f155739c1f7b2835ed66a0072840d76d2711c6b215bd3f580cffdc9d0b0120b2fa8a14781ce893707f3361bd6534932ba199
diff --git a/mate-base/libmatekbd/libmatekbd-1.28.0.ebuild b/mate-base/libmatekbd/libmatekbd-1.28.0.ebuild
new file mode 100644
index 000000000000..cfdf0de3b917
--- /dev/null
+++ b/mate-base/libmatekbd/libmatekbd-1.28.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE keyboard configuration library"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="X +introspection test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.24:2
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.2:0[introspection?]
+ x11-libs/pango
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_with X x) \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}