summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/fcitx-qt/Manifest1
-rw-r--r--app-i18n/fcitx-qt/fcitx-qt-5.1.3.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/app-i18n/fcitx-qt/Manifest b/app-i18n/fcitx-qt/Manifest
index 461fde3dae41..414c8e399b34 100644
--- a/app-i18n/fcitx-qt/Manifest
+++ b/app-i18n/fcitx-qt/Manifest
@@ -1,2 +1 @@
-DIST fcitx-qt-5.1.3.tar.xz 92312 BLAKE2B 84dda11e955ab1317379e0f5a0e95efb1b3108844b52c0e8fd08a02f0d5d6d16094c8729820ad7dce51e3d77994c217710f69edff4d566251f9272a125ffc936 SHA512 7d02409ac8359cea5e199f16b3b06ecfe47886edb00bb2163f9fbe1c319bbef425387e58db25fdfcd2b35261eada35f2acfb93ff0b65ed497da62d35363e8947
DIST fcitx-qt-5.1.4.tar.xz 92880 BLAKE2B b165740e173fe21e8953b5605713c0250265e4906c25a56c5320f2560d261a9b8d4111f0960287b08fa7ac18c917d0da737fb1022bba7f76ca2e2e00d2d4f060 SHA512 942999327415e3d4195c18c2fb02e12a313e3a2cf1dd1e32d0e6a7a98b625bcc1b3a7278934bb583a029dee43a271dba9bac75face42729249557f60e1146adf
diff --git a/app-i18n/fcitx-qt/fcitx-qt-5.1.3.ebuild b/app-i18n/fcitx-qt/fcitx-qt-5.1.3.ebuild
deleted file mode 100644
index 909c9559ce68..000000000000
--- a/app-i18n/fcitx-qt/fcitx-qt-5.1.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PN="fcitx5-qt"
-
-inherit cmake
-
-DESCRIPTION="Qt library and IM module for fcitx5"
-HOMEPAGE="https://github.com/fcitx/fcitx5-qt"
-SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
-
-LICENSE="BSD LGPL-2.1+"
-SLOT="5"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="+qt5 onlyplugin staticplugin qt6 wayland"
-REQUIRED_USE="
- || ( qt5 qt6 )
- staticplugin? ( onlyplugin )
-"
-
-RDEPEND="
- x11-libs/libX11
- x11-libs/libxcb
- x11-libs/libxkbcommon
- !onlyplugin? (
- >=app-i18n/fcitx-5.1.5:5
- qt5? ( dev-qt/qtconcurrent:5 )
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5=
- dev-qt/qtwidgets:5
- )
- qt6? (
- dev-qt/qtbase:6[dbus,gui,widgets,wayland?]
- wayland? ( dev-qt/qtwayland:6 )
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- kde-frameworks/extra-cmake-modules:0
- virtual/pkgconfig
- !onlyplugin? ( sys-devel/gettext )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-PATCHES="${FILESDIR}/${P}-make-qwayland-workaround-optional.patch"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_QT4=no
- -DENABLE_QT5=$(usex qt5)
- -DENABLE_QT6=$(usex qt6)
- -DENABLE_QT6_WAYLAND_WORKAROUND=$(usex wayland)
- -DBUILD_ONLY_PLUGIN=$(usex onlyplugin)
- -DBUILD_STATIC_PLUGIN=$(usex staticplugin)
- )
- cmake_src_configure
-}