summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/rtmpdump/Manifest1
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/media-video/rtmpdump/Manifest b/media-video/rtmpdump/Manifest
index b4b21a60f340..35146f804b0c 100644
--- a/media-video/rtmpdump/Manifest
+++ b/media-video/rtmpdump/Manifest
@@ -1 +1,2 @@
DIST rtmpdump-2.4_p20131018.tar.gz 142707 SHA256 57164e0c12f7cbff8e40b1e66cf6b889086387324851a115b427b8d2b3fff267 SHA512 78c2da880ece43af1d4257a14a22d95e9f1b9f474d85f97e879d9cfd2232c5a7f1c1a41fbb1af7e047700214a993eb33965dba41573389d5eebefd3f01a780fc WHIRLPOOL 80a8e9ed9eeca4ddab8c44ae6e937f0d271311e8f5ce74bb0b49fff69edc4bd302f257366f33cceb8ae089fabdd7ff2533937a833e79fcb575e3cf43c592327a
+DIST rtmpdump-2.4_p20161210.tar.gz 142837 SHA256 d6da3b683f1045f02d94a81b0c583318dba021f69bdab970c5d5d73e8c38860f SHA512 76617f02c13d7e8e3a7cf2734c6174e56fb321a881c9e4869bf6393786b193e0c01a8c530ecbf0679cc888c523af5712f2dcb2031fbd09729b7ddeebc3a4b133 WHIRLPOOL 06fd296825c06339dd9210d626f503ab8f7bc929fa363106a166882bff3e7531ce11636dd716c1259558301c258c190a7f6e550fd39dae51dea809526b566d8d
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild
new file mode 100644
index 000000000000..c4dda6d3102f
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20161210.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit multilib toolchain-funcs multilib-minimal flag-o-matic
+
+DESCRIPTION="RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+# the library is LGPL-2.1, the command is GPL-2
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="gnutls polarssl ssl libressl"
+
+DEPEND="ssl? (
+ gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)] )
+ polarssl? ( !gnutls? ( >=net-libs/polarssl-1.3.4[${MULTILIB_USEDEP}] ) )
+ !gnutls? ( !polarssl? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl ) ) )
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use ssl && { use gnutls || use polarssl; }; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_unpack() {
+ mkdir -p "${S}" || die "Can't create source directory"
+ cd "${S}" || die
+ unpack ${A}
+}
+
+src_prepare() {
+ # fix #571106 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ # fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+ sed -i -e 's:OPT=:&-fPIC :' \
+ -e 's:OPT:OPTS:' \
+ -e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
+ || die "failed to fix Makefile"
+ multilib_copy_sources
+ eapply_user
+}
+
+multilib_src_compile() {
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+ #fix multilib-script support. Bug #327449
+ sed -i "/^libdir/s:lib$:$(get_libdir):" librtmp/Makefile || die
+ if ! multilib_is_native_abi; then
+ cd librtmp || die
+ fi
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
+}
+
+multilib_src_install() {
+ mkdir -p "${ED}"/usr/$(get_libdir) || die
+ if multilib_is_native_abi; then
+ dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
+ else
+ cd librtmp || die
+ fi
+ emake DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" \
+ CRYPTO="${crypto}" install
+}