summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vkd3d/Manifest1
-rw-r--r--app-emulation/vkd3d/vkd3d-1.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index 02a02405b934..0a0556b2bf5b 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1 +1,2 @@
DIST vkd3d-1.6.tar.xz 785844 BLAKE2B 6dff7aaad966b378809c87969a54568b943c52bec072fa03becdb40c4ff098168924c363e642aa42049f4468ff75013175fb847cc213278a4e10ea54e906a288 SHA512 0f640c1b139f5ccce8e6d1986d1439c2b0d14e7ac533216d2408dbeee07172eee51549311db22464c2ae89070ca15191aaffd967749676586984561ce1d4b38f
+DIST vkd3d-1.7.tar.xz 807176 BLAKE2B 1e2b03c8440bdf9306e9c08d557dd6b622c689e94f7d4bcb4ce752cbfbe48ddb0b577f9fee14ab8ac2fc08395205328efc5b437a8fc67d5bb0fd868db0902378 SHA512 008c63742d939e8dc755bd382208d52e145d3ad7a5fe7ae71d41be3e3efd609b513add2ec43c6947a183b6a7595e3f0d8bdc6628835577fa5b7f7ec8a5dea347
diff --git a/app-emulation/vkd3d/vkd3d-1.7.ebuild b/app-emulation/vkd3d/vkd3d-1.7.ebuild
new file mode 100644
index 000000000000..cea4a98c8e5e
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+}