summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/uuid/Manifest1
-rw-r--r--dev-haskell/uuid/uuid-1.3.13-r1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/uuid/Manifest b/dev-haskell/uuid/Manifest
index f2d8ed08c06c..6cacd27d67e7 100644
--- a/dev-haskell/uuid/Manifest
+++ b/dev-haskell/uuid/Manifest
@@ -1,2 +1,3 @@
DIST uuid-1.3.11.tar.gz 8578 BLAKE2B ab865736dda4ca4188b9b21b06649fde81d8de1ef4939bf0a5945353d17da691fcd267faded8f64edec7371727a99239f961b25b3402f8fb68b5f0ad89052bae SHA512 3b94c13ff8b6a631f9411a313a99251ee961234d0322e446e22b04110728a4acb687f4bb4b83f9b09268fed9238b1265dc53c5214ae4bb8e18c12455c41c41e5
DIST uuid-1.3.12.tar.gz 8738 BLAKE2B a6e8fe96d6c20b9294c1535d367ad3ce0a91dfec4c9cd408d5b7e2ec0988326721db3d7a6ea3addded81c12f86692ed898e14612c20fcaf16f0ea6be6f2ef21c SHA512 53d1a9e69dbc3ce2cb2e35aeca9b116e5fbf176fe048d4afaaff1bfaae80445da8e3d53c4652ada41791fb3e237e2cd24d3ac15e6a786242844fdf076588dae9
+DIST uuid-1.3.13.tar.gz 8926 BLAKE2B d7b4850eb921467677534d33475dccb90b2e74a4f73137eb8e9a45573a337d4152b19f052dea584bb0b6ab862dcdf764106c4e35efa1e8ae3ecec41becc75a4e SHA512 e888e6350a32c6496b0b57384797925c78ab1c4dc674d296972981fa81338b4705d21a96960a63771aa5b9a785efd507ecaad195767dba7847fcab5ca7f3f923
diff --git a/dev-haskell/uuid/uuid-1.3.13-r1.ebuild b/dev-haskell/uuid/uuid-1.3.13-r1.ebuild
new file mode 100644
index 000000000000..31f07bace4ef
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.13-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/hvr/uuid"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cryptohash-md5-0.11.100:=[profile?] <dev-haskell/cryptohash-md5-0.12:=[profile?]
+ >=dev-haskell/cryptohash-sha1-0.11.100:=[profile?] <dev-haskell/cryptohash-sha1-0.12:=[profile?]
+ >=dev-haskell/entropy-0.3.7:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-2:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/tasty-0.10
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && < 2.10' 'QuickCheck >= 2.4' \
+ 'time >= 1.1 && < 1.8' 'time >= 1.1' \
+ 'tasty >= 0.10 && < 0.12' 'tasty >= 0.10' \
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9' \
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
+ 'HUnit >= 1.2 && < 1.4' 'HUnit >= 1.2' \
+ 'entropy >= 0.3.7 && < 0.4' 'entropy >= 0.3.7'
+}