summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-forensics/aflplusplus/Manifest1
-rw-r--r--app-forensics/aflplusplus/aflplusplus-4.08c.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/app-forensics/aflplusplus/Manifest b/app-forensics/aflplusplus/Manifest
index 802e3724f442..1d808f455616 100644
--- a/app-forensics/aflplusplus/Manifest
+++ b/app-forensics/aflplusplus/Manifest
@@ -1,2 +1,3 @@
DIST aflplusplus-4.07c-patches.tar.xz 4788 BLAKE2B de109198fbabfce2554459fee6a14f66002a952f5584ff265a6ff7d7646f520ed53a6d9c8c125a05eb5a4aa0c1cc675dca82647ad4c0965cdab10d3aa2f09467 SHA512 0ea4279b261d55cf209e32ca4b7fd7dc1181ec902dd7e4c7f36854d84f14037e643a543dcbb849927b41919c527303fc5877c9fab5b09c8988fbfab499b8f8bc
DIST aflplusplus-4.07c.tar.gz 2878659 BLAKE2B c3c4c5507e29ed8015784378a13a55cb6b389dec915979749b1869496c16366ce876f1eecc91eb09d51cc58266a92296218cd5eda2a201f5cf4faaa2ea61942f SHA512 c62fce112d59ef5ffb847adab9a7ff8486d44e6316a391392979da19a8160b55f9af7f75fd39cdc98997b3e166f4f6a33ddf31b827c9414a1392657701ecb5e8
+DIST aflplusplus-4.08c.tar.gz 2894794 BLAKE2B 5576ec54969c7ae10b05fe10320581b348f989c1bc412bd63b2ca7ecb3bd1782a90c2660d971375667f6dd820f9035d7abb2207f59a1aaa5e7640d352eaa5757 SHA512 52c35ed544db8be778b79a64977fcc74092b541c4c07a788b20f4b9e8db95ff9c52c997ebf6f5a1056f962f3551df06a5eca02679bc2b71bb9d8944c1f77984a
diff --git a/app-forensics/aflplusplus/aflplusplus-4.08c.ebuild b/app-forensics/aflplusplus/aflplusplus-4.08c.ebuild
new file mode 100644
index 000000000000..51cd62ea7a29
--- /dev/null
+++ b/app-forensics/aflplusplus/aflplusplus-4.08c.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+LLVM_MAX_SLOT=17
+inherit toolchain-funcs llvm optfeature python-single-r1
+
+AFL_PATCHSET="${PN}-4.07c-patches"
+DESCRIPTION="Fork of AFL, the popular compile-time instrumentation fuzzer"
+HOMEPAGE="https://github.com/AFLplusplus/AFLplusplus"
+SRC_URI="https://github.com/AFLplusplus/AFLplusplus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${AFL_PATCHSET}.tar.xz"
+S="${WORKDIR}"/AFLplusplus-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests involve heavy use of LD_PRELOAD in some cases
+# This isn't compatible with sandbox
+RESTRICT="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):=
+ || (
+ sys-devel/clang:14
+ sys-devel/clang:15
+ sys-devel/clang:${LLVM_MAX_SLOT}
+ )
+ !app-forensics/afl
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )
+"
+
+QA_FLAGS_IGNORED="
+ usr/lib.*/afl/afl-gcc-cmplog-pass.so
+ usr/lib.*/afl/afl-gcc-cmptrs-pass.so
+"
+QA_PREBUILT="usr/share/afl/testcases/others/elf/small_exec.elf"
+
+PATCHES=(
+ "${WORKDIR}"/${AFL_PATCHSET}
+)
+
+llvm_check_deps() {
+ has_version -b "sys-devel/clang:${LLVM_SLOT}" && \
+ has_version -b "sys-devel/llvm:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ llvm_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+mymake() {
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS_FLTO="" \
+ LLVM_CONFIG="$(get_llvm_prefix ${LLVM_MAX_SLOT})"/bin/llvm-config \
+ PREFIX="${EPREFIX}/usr" \
+ HELPER_PATH="${EPREFIX}/usr/$(get_libdir)/afl" \
+ DOC_PATH="${EPREFIX}/usr/share/doc/${PF}" \
+ MAN_PATH="${EPREFIX}/usr/share/man/man8" \
+ "$@"
+}
+
+src_compile() {
+ mymake
+}
+
+src_test() {
+ mymake test
+}
+
+src_install() {
+ mymake DESTDIR="${D}" install
+ dostrip -x /usr/share/afl/testcases/
+}
+
+pkg_postinst() {
+ # TODO: Any others?
+ optfeature "fuzzing with AFL_USE_ASAN" sys-libs/compiler-rt-sanitizers[asan]
+ optfeature "fuzzing with AFL_USE_MSAN" sys-libs/compiler-rt-sanitizers[msan]
+}