summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fqdn/Manifest1
-rw-r--r--dev-python/fqdn/files/1.4.0-tests.patch24
-rw-r--r--dev-python/fqdn/fqdn-1.4.0.ebuild22
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/fqdn/Manifest b/dev-python/fqdn/Manifest
index 2e958ef421fa..04484d55d492 100644
--- a/dev-python/fqdn/Manifest
+++ b/dev-python/fqdn/Manifest
@@ -1 +1,2 @@
DIST fqdn-1.2.0.tar.gz 12275 BLAKE2B 0bc862863ee3b196ea08a1f4f50f98dca88e8b81f37d2cb97bd3fd74ef9844157ea7a9f38707047fad17b95fb95c2f0e7ace8ad2c2310171cba6ff43471ae63d SHA512 ddfcfd82860d597075fd2d989d4bb1cd8c1dc79b711da432732bf786032e78b9356e04851a491c5299b336dcde173a66ddae0e23aea59b67c758d997554b494e
+DIST fqdn-1.4.0.tar.gz 12962 BLAKE2B 76b7bd7f2ebfd77b2bba04f7e07cdab42f0ff6c7ad5967f52e4c108fc3c3345c88a220b9f0330d998dc5abc53909d5768b1b52e08e48bc1e16009fa39f3afa16 SHA512 e2a67e97bc832526e234bbf19600af2e7eda8f7ede13ba33ec8c736888d19693727eded4b895efd4c88ab2e232db768d42761f44a479e615e13da8ddbf6d03a3
diff --git a/dev-python/fqdn/files/1.4.0-tests.patch b/dev-python/fqdn/files/1.4.0-tests.patch
new file mode 100644
index 000000000000..0804be7d175b
--- /dev/null
+++ b/dev-python/fqdn/files/1.4.0-tests.patch
@@ -0,0 +1,24 @@
+From 0d6a6191a49fac252a96f72bd3193f21ae56424f Mon Sep 17 00:00:00 2001
+From: ypcrts <32625281+ypcrts@users.noreply.github.com>
+Date: Sun, 26 Apr 2020 01:51:43 -0400
+Subject: [PATCH] test __str__ to be congruent with absolute
+
+---
+ tests/test_fqdn.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_fqdn.py b/tests/test_fqdn.py
+index 37fcf52..60c8607 100644
+--- a/tests/test_fqdn.py
++++ b/tests/test_fqdn.py
+@@ -21,8 +21,8 @@ def test_constructor_raises_on_bytes(self):
+
+ def test_str(self):
+ d = "greatdomain.com"
+- assert d == str(FQDN(d))
+- assert d == str(FQDN(d + "."))
++ f = FQDN(d)
++ assert f.absolute == str(f)
+
+ def test_rfc_1035_s_2_3_4__label_max_length(self):
+ self.__assert_valid(
diff --git a/dev-python/fqdn/fqdn-1.4.0.ebuild b/dev-python/fqdn/fqdn-1.4.0.ebuild
new file mode 100644
index 000000000000..e27e15d6d77a
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://github.com/guyhughes/fqdn"
+SRC_URI="https://github.com/guyhughes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/cached-property[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/1.4.0-tests.patch" )
+
+distutils_enable_tests unittest