summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/hath/Manifest1
-rw-r--r--net-misc/hath/hath-0.5.8.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/hath/Manifest b/net-misc/hath/Manifest
index feae8c85fb73..de4f86033bcc 100644
--- a/net-misc/hath/Manifest
+++ b/net-misc/hath/Manifest
@@ -1 +1,2 @@
DIST hath-0.5.7.tar.gz 31087 BLAKE2B 2449872bae187dfd67ab94da7df55bec7a9735bcd85a9dbd96ef7ce1afdd3f83ed666eb02b6de54719ba32b96de75ff168136f07760023ea2db7bb55bf51f70e SHA512 daa1ae22e8a01f63db6849c7c9e90917051644c681848c66bbd5cb7178326a125868c9f52d506bb5561595fd1bb8b16ae922b91e1be44ccb86e346fc1730a6dd
+DIST hath-0.5.8.tar.gz 31116 BLAKE2B 3d6f91b1e286bbb88feab5f30a9164f19ae0bb886d39dd8c945b4c2b61106b6d9a233511b704b96c15176e9152f63d891f72a3ad11b64c8043e03c20ff705365 SHA512 c5a50e8c976f92f5d8fa3750098850f50198a3a07342e6fa3a2fa2faeb5e850780aef17d648781379a419671011f24749a0f24ca5c9d98cd48c94b0e5c871017
diff --git a/net-misc/hath/hath-0.5.8.ebuild b/net-misc/hath/hath-0.5.8.ebuild
new file mode 100644
index 000000000000..e3bd3cee062a
--- /dev/null
+++ b/net-misc/hath/hath-0.5.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Manipulate network blocks in CIDR notation"
+HOMEPAGE="https://michael.orlitzky.com/code/hath.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/cmdargs-0.10:=
+ >=dev-haskell/split-0.2:=
+ >=dev-haskell/tasty-0.8:=
+ >=dev-haskell/tasty-hunit-0.8:=
+ >=dev-haskell/tasty-quickcheck-0.8.1:=
+ >=dev-lang/ghc-9.0.0:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-util/shelltestrunner )
+"
+
+src_install() {
+ cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}