summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
index dd2b48641bc5..5d4a3524b53e 100644
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ b/dev-python/loky/loky-2.9.0.ebuild
@@ -25,10 +25,14 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- # docker, seriously?
- sed -e 's:test_cpu_count_cfs_limit:_&:' \
- -i tests/test_loky_module.py || die
-
- distutils-r1_src_prepare
+python_test() {
+ local args=(
+ # docker, seriously?
+ --deselect 'tests/test_loky_module.py::test_cpu_count_cfs_limit'
+ # one test that uses a lot of memory, also broken on 32-bit
+ # platforms
+ --skip-high-memory
+ )
+
+ pytest -vv "${args[@]}" || die "Tests failed on ${EPYTHON}"
}