summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libutf8proc/Manifest1
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.5.0.ebuild42
-rw-r--r--dev-libs/libutf8proc/metadata.xml1
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libutf8proc/Manifest b/dev-libs/libutf8proc/Manifest
index 88837e1a87f9..c73e10750f0c 100644
--- a/dev-libs/libutf8proc/Manifest
+++ b/dev-libs/libutf8proc/Manifest
@@ -1,2 +1,3 @@
DIST libutf8proc-2.2.0-1-src.tar.gz 156447 BLAKE2B 1ccf32760bcb8a0d4d9fbf94177ffee97e735a8cb309d5522df1b5ecd5f313a6d0c681209adb066c16ac65573c9c1edaa336b52de1b057a4b74ed6a7e9ca2671 SHA512 eedaafb2fdb3b6bd47da002a48043c26c1cd3c6b96c447a02f2fea19954c1689dcdb5f64b7c662dd8c5de4f971d75b2d69c8483bd29d49675ef47b362ad0c9ad
DIST libutf8proc-2.4.0.tar.gz 154936 BLAKE2B a4fea823806bb784c83504de2ade985d3f0e86aa8d64747f389724ef10122953312e398a7a342cf28f25502693ee507be246338dba37c976998f6a1922cd94c5 SHA512 2bbd056b488cd30faca26618389d8af84edc39ade9b705e147b676bf39eee65b40239d01c32c46dfc2a289d79e869ed1bb3c347365603dcaab2f69e34427441a
+DIST libutf8proc-2.5.0.tar.gz 155485 BLAKE2B a0cd9285e7f171b9449d9d98f91173bad2b793a00a9c10287c43cc2050b6a0306e289cbd3b4faebb0d97fd305b77ecbb7ce11f119d9ead2a580029db0d7ad898 SHA512 0c553faf4f3841c17c7aa4cce1e917b1585c430ac3f7f240ab98cbe01b9743f2074532e6f71faf3df030f5af00e483a3faf9716a67e6a4b1bb66a3de48308014
diff --git a/dev-libs/libutf8proc/libutf8proc-2.5.0.ebuild b/dev-libs/libutf8proc/libutf8proc-2.5.0.ebuild
new file mode 100644
index 000000000000..776f2dc9a1e3
--- /dev/null
+++ b/dev-libs/libutf8proc/libutf8proc-2.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A clean C Library for processing UTF-8 Unicode data"
+HOMEPAGE="https://github.com/JuliaStrings/utf8proc"
+SRC_URI="https://github.com/JuliaStrings/${PN#lib}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( =app-i18n/unicode-data-13.0* )"
+S="${WORKDIR}/${P#lib}"
+
+PATCHES=( "${FILESDIR}"/${PN}-grapheme-test.patch )
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ prefix="/usr" \
+ libdir="/usr/$(get_libdir)" \
+ install
+ use static-libs || find "${ED}" -name '*.a' -delete || die
+}
+
+src_test() {
+ cp "${EPREFIX}"/usr/share/unicode-data/{Normalization,auxiliary/GraphemeBreak}Test.txt data || die
+
+ emake CC="$(tc-getCC)" check
+}
diff --git a/dev-libs/libutf8proc/metadata.xml b/dev-libs/libutf8proc/metadata.xml
index 8af506602427..7ffc4339bc56 100644
--- a/dev-libs/libutf8proc/metadata.xml
+++ b/dev-libs/libutf8proc/metadata.xml
@@ -3,5 +3,6 @@
<pkgmetadata>
<maintainer type="person">
<email>hattya@gentoo.org</email>
+ <name>Akinori Hattori</name>
</maintainer>
</pkgmetadata>