summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/distutils-r1.eclass3
1 files changed, 3 insertions, 0 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 4ec252958408..a81d95f4eb6e 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -544,6 +544,9 @@ esetup.py() {
if [[ ${DISTUTILS_USE_SETUPTOOLS} == pyproject.toml ]]; then
setup_py=( -m pyproject2setuppy )
elif [[ ! -f setup.py ]]; then
+ if [[ ! -f setup.cfg ]]; then
+ die "${FUNCNAME}: setup.py nor setup.cfg not found"
+ fi
setup_py=( -c "from setuptools import setup; setup()" )
fi