summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-1.4.0.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 1c7f0d77d3bc..962b03040073 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,3 +1,2 @@
DIST xcffib-1.3.0.tar.gz 89874 BLAKE2B 5dd8d64b906d92cb987ee4398da668d6034faf4abc24a56c0fca3e5b6d0cd1252ea1459736a9f7fb83ee97d4d6cec5d103eb19aba626a3d646f67e6332e255a5 SHA512 a493f86891158ffa0c36168da5e7ebdeadafe5e9f067e2ad6052cf302c89db612f907b5e9950748fcfd74886b808870986529902bae77fede7e27d5d422d6ec6
-DIST xcffib-1.4.0.tar.gz 89496 BLAKE2B 4987d9346d403c3ac627cd7b1b31d3686b9135d077c4b61862841085cc1c1ea7f950bd0b6c456d59f407bb384d14a96cf2a617f2c584434eee294a22ac770a82 SHA512 310fc4c21856d2255650598c26831569061e112516d958e6f65a0a8e6d32c4bb37a14d7bb6c7da8dcaa9c4459fc83026ba9b1a9567f01f9bbcafda8fdea4f153
DIST xcffib-1.5.0.tar.gz 89544 BLAKE2B cb3820a53eb7694078e5dbb175951b6dbdc445c06f397898e52319fd8a7633f2d8115f0d096a14b2b3de0c7b07918343d077705814574ff41de2bf06a12812c0 SHA512 aaa426b57d0d8dc45cb6a2036c862af6308fb5781667b8dba3f5ff399fe5e15912860d0bb696ac09f1efd4ffbbdaf7f555ef76039bd660f36f5c6179535b654f
diff --git a/dev-python/xcffib/xcffib-1.4.0.ebuild b/dev-python/xcffib/xcffib-1.4.0.ebuild
deleted file mode 100644
index 0d55d90c6c0c..000000000000
--- a/dev-python/xcffib/xcffib-1.4.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
-HOMEPAGE="
- https://github.com/tych0/xcffib/
- https://pypi.org/project/xcffib/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-DEPEND="
- x11-libs/libxcb
-"
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
- ' 'python*')
- ${DEPEND}
-"
-BDEPEND="
- test? (
- x11-base/xorg-server[xvfb]
- x11-apps/xeyes
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf xcffib || die
- epytest
-}