summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libfmt/libfmt-6.1.2.ebuild5
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/libfmt/libfmt-6.1.2.ebuild b/dev-libs/libfmt/libfmt-6.1.2.ebuild
index fc0c0c0b8bef..78c2d74959bb 100644
--- a/dev-libs/libfmt/libfmt-6.1.2.ebuild
+++ b/dev-libs/libfmt/libfmt-6.1.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Small, safe and fast formatting library"
@@ -31,5 +32,5 @@ multilib_src_configure() {
-DFMT_LIB_DIR="$(get_libdir)"
-DFMT_TEST=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
index fc0c0c0b8bef..78c2d74959bb 100644
--- a/dev-libs/libfmt/libfmt-9999.ebuild
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Small, safe and fast formatting library"
@@ -31,5 +32,5 @@ multilib_src_configure() {
-DFMT_LIB_DIR="$(get_libdir)"
-DFMT_TEST=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}