summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/driftnet/Manifest1
-rw-r--r--net-analyzer/driftnet/driftnet-1.3.0.ebuild67
-rw-r--r--net-analyzer/driftnet/files/driftnet-1.3.0-CFLAGS.patch21
-rw-r--r--net-analyzer/driftnet/files/driftnet-1.3.0-gtk.patch13
4 files changed, 0 insertions, 102 deletions
diff --git a/net-analyzer/driftnet/Manifest b/net-analyzer/driftnet/Manifest
index 64dfbfd50327..bfbea558151d 100644
--- a/net-analyzer/driftnet/Manifest
+++ b/net-analyzer/driftnet/Manifest
@@ -1,2 +1 @@
DIST driftnet-0.1.6_p20090401.tar.gz 43683 BLAKE2B a3f5c57c5f57247feca37815b84630422f9fdb9ec978791eadaaf0f0b51d1f744674931ea9bb1b9291fc9e556ec9758ff44210a442d219ceeabf71e0ea3a193f SHA512 93b2f7b644603bf2fea09163c3c8cc6eed7ed61f3ad7f6770a754e1a31afde5a75e27464c399261bfdafbe37729f201e6bbcb06bb6c59bf52ac0ede4393a15fa
-DIST driftnet-1.3.0.tar.gz 4971618 BLAKE2B 1cf0a46caac2267c093bf21a0d8e150518dbfe0e76acbe21ef87cd760ccbe964313116ee24d25ad7759b3eeba19ef7925200caee4fd06bb28f9836217d889256 SHA512 45f1016a850cf9e5e294756e47e40eccb13f57a316ae7fa885eac2d5e53f68b9d9ef86868415eca76b108f7aa1f4080c550a91f789265edb0f6e3a55e05f5f0c
diff --git a/net-analyzer/driftnet/driftnet-1.3.0.ebuild b/net-analyzer/driftnet/driftnet-1.3.0.ebuild
deleted file mode 100644
index a53b4a5dedf6..000000000000
--- a/net-analyzer/driftnet/driftnet-1.3.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools fcaps toolchain-funcs
-
-DESCRIPTION="Watches network traffic and displays media from TCP streams observed"
-HOMEPAGE="http://www.ex-parrot.com/~chris/driftnet/"
-SRC_URI="https://github.com/deiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm64 -sparc ~x86"
-SLOT="0"
-IUSE="debug gtk suid test"
-
-RDEPEND="
- net-libs/libpcap
- net-libs/libwebsockets:=[client,http-proxy,socks5]
- gtk? (
- media-libs/giflib:=
- media-libs/libpng:=
- virtual/jpeg:0
- x11-libs/gtk+:2
- )
-"
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- ${RDEPEND}
- test? ( dev-util/cmocka )
-"
-DOCS="
- Changelog CREDITS README.md TODO
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.0-CFLAGS.patch
- "${FILESDIR}"/${PN}-1.3.0-gtk.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable gtk display)
-}
-
-src_install() {
- default
-
- gzip -d "${ED}"/usr/share/man/man1/${PN}.1.gz || die
-
- if use suid ; then
- elog "marking the no-display driftnet as setuid root."
- fowners root:wheel "/usr/bin/driftnet"
- fperms 710 "/usr/bin/driftnet"
- fperms u+s "/usr/bin/driftnet"
- fi
-}
-
-pkg_postinst() {
- fcaps \
- cap_dac_read_search,cap_net_raw,cap_net_admin \
- "${EROOT}"/usr/bin/driftnet
-}
diff --git a/net-analyzer/driftnet/files/driftnet-1.3.0-CFLAGS.patch b/net-analyzer/driftnet/files/driftnet-1.3.0-CFLAGS.patch
deleted file mode 100644
index 2b25ed45833a..000000000000
--- a/net-analyzer/driftnet/files/driftnet-1.3.0-CFLAGS.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -68,12 +68,12 @@
- ,
- [enable_debug=yes])
-
--if test "x$enable_debug" = xyes; then
-- CFLAGS="-O2 -g -DDEBUG"
--else
-- CFLAGS="-O2 -DNDEBUG"
--fi
--#AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
-+#if test "x$enable_debug" = xyes; then
-+# CFLAGS="-O2 -g -DDEBUG"
-+#else
-+# CFLAGS="-O2 -DNDEBUG"
-+#fi
-+AM_CONDITIONAL(ENABLE_DEBUG, test "$enable_debug" = "yes")
-
- #
- # Checks for programs.
diff --git a/net-analyzer/driftnet/files/driftnet-1.3.0-gtk.patch b/net-analyzer/driftnet/files/driftnet-1.3.0-gtk.patch
deleted file mode 100644
index 2a8a294e8dbe..000000000000
--- a/net-analyzer/driftnet/files/driftnet-1.3.0-gtk.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/options.h
-+++ b/src/options.h
-@@ -32,10 +32,8 @@
- char *audio_mpeg_player;
- int mpeg_player_specified;
- int newpfx;
--#ifndef NO_DISPLAY_WINDOW
- char *savedimgpfx;
- int enable_gtk_display;
--#endif
- char *drop_username;
- int list_interfaces;
- int monitor_mode;