summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/fish/Manifest2
-rw-r--r--app-shells/fish/fish-2.6.0.ebuild70
-rw-r--r--app-shells/fish/fish-3.0_beta1.ebuild72
3 files changed, 0 insertions, 144 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index 247bec50bdc2..f6ea60fabfe4 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,4 +1,2 @@
-DIST fish-2.6.0.tar.gz 3575346 BLAKE2B 8697dc6e50836d93d0ed22663e86016fec8e567cd4e129ea92008f52da6dd629bf11b70719beabe5c08bd3d7ba43d8017441f103d49a82c0faec3bc749e83764 SHA512 d4ded5ce24600e85673a7bb016e9dc36bce999b27f40e6b1ce0b9ca49a421be2d444d9d2b6f178f6eee963e59daa4a65df4c3de2a8086a610486f758fcfb0ed1
DIST fish-2.7.1.tar.gz 5760550 BLAKE2B 71568a3a17f4222b05a314464a61fceb241409a7d42c46249486ca742ef0cf990c46d693bcc22521c18f58a558e6aab35759d0da6eb62ee6611a2a7946fe714d SHA512 45ee3453404c5d6c56d307b4cd19197de862f9f42d7fa06461acec56dea7146db5675cf6419dd5f72e939b3e4b1955d3761098df1de89a8cebe47645eb6f7a4b
DIST fish-3.0.0.tar.gz 6472393 BLAKE2B 9a8226ca4dce40a7bbc62ad5791c5238d1257cebea296cd97a195438d771d7394acb012be6af118bf355a9b6e391ddee1061d83298356f664e0d5dbe3d859012 SHA512 e4159821d4263e5afb67adee82e30cfed0ad30f3772dd95beb0df71423ff52c21354970f64967f2de9fd1d31caa702208cfd9f2ce281bbf33114f3aa7cd539a2
-DIST fish-3.0b1.tar.gz 6471932 BLAKE2B d65ed7e7f4de1f967f5f2090b01be86b778a46f8e5c112daf99234bc584e01992c466976d6547814f84730d1092e39bc3f2bfa55592e71bf1a93a42fb8846b34 SHA512 f13c4ca9e62ecdd6afc4961cb4f6ec5d4b7f51b9c3b3ba97f280b7a9ed2cdeb9be193ff58b9f556b01af0815b78ab540f25c473a253651c96db03f8cb1652dde
diff --git a/app-shells/fish/fish-2.6.0.ebuild b/app-shells/fish/fish-2.6.0.ebuild
deleted file mode 100644
index 2d5bbce6f54d..000000000000
--- a/app-shells/fish/fish-2.6.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Friendly Interactive SHell"
-HOMEPAGE="http://fishshell.com/"
-SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="nls"
-
-RDEPEND="
- >=dev-libs/libpcre2-10.21[pcre32]
- sys-libs/ncurses:0=
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/bc
- nls? ( sys-devel/gettext )
-"
-
-src_configure() {
- # Set things up for fish to be a default shell.
- # It has to be in /bin in case /usr is unavailable.
- # Also, all of its utilities have to be in /bin.
- econf \
- docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --bindir="${EPREFIX}"/bin \
- --without-included-pcre2 \
- $(use_with nls gettext)
-}
-
-src_test() {
- if has_version ~${CATEGORY}/${P} ; then
- emake test
- else
- ewarn "The test suite only works when the package is already installed"
- fi
-}
-
-pkg_postinst() {
- elog "fish is now installed on your system."
- elog "To run fish, type 'fish' in your terminal."
- elog
- elog "It is advised not to set fish as a default login shell."
- elog "see bug #545830 for more details."
- elog "Executing fish using ~/.bashrc is an alternative"
- elog "see https://wiki.gentoo.org/wiki/Fish#Caveats for details"
- elog
- elog "To set your colors, run 'fish_config'"
- elog "To scan your man pages for completions, run 'fish_update_completions'"
- elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
- elog
- elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
- elog "browser of your choice to get acces to ${PN}'s help system:"
- elog " BROWSER=\"/usr/bin/firefox\""
- elog
- elog "In order to get lzma and xz support for man-page completion please"
- elog "emerge one of the following packages:"
- elog " dev-python/backports-lzma"
- elog " >=dev-lang/python-3.3"
- elog
- elog "If you have issues with cut'n'paste in X-terminals, install the"
- elog "x11-misc/xsel package."
- elog
- elog "Have fun!"
-}
diff --git a/app-shells/fish/fish-3.0_beta1.ebuild b/app-shells/fish/fish-3.0_beta1.ebuild
deleted file mode 100644
index cc6e0bba6178..000000000000
--- a/app-shells/fish/fish-3.0_beta1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils readme.gentoo-r1
-
-DESCRIPTION="Friendly Interactive SHell"
-HOMEPAGE="http://fishshell.com/"
-
-MY_PV="${PV/_beta/b}"
-MY_P="${PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
-else
- SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="doc nls test"
-
-RDEPEND="
- >=dev-libs/libpcre2-10.21[pcre32]
- sys-devel/bc
- sys-libs/ncurses:0=
-"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )
- test? ( dev-tcltk/expect )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # workaround for https://github.com/fish-shell/fish-shell/issues/4883
- sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
- cmake/Tests.cmake || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
- -DINTERNAL_WCWIDTH=OFF
- -DBUILD_DOCS="$(usex doc)"
- -DWITH_GETTEXT="$(usex nls)"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
- readme.gentoo_create_doc
-}
-
-src_test() {
- cmake-utils_src_make -j1 test
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}