summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/geoipupdate/Manifest2
-rw-r--r--net-misc/geoipupdate/files/geoipupdate-6.0.0-use-go-md2man-instead-of-pandoc.patch26
-rw-r--r--net-misc/geoipupdate/geoipupdate-6.0.0.ebuild48
3 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/geoipupdate/Manifest b/net-misc/geoipupdate/Manifest
index c819bce50ae6..60f008f21d40 100644
--- a/net-misc/geoipupdate/Manifest
+++ b/net-misc/geoipupdate/Manifest
@@ -1,2 +1,4 @@
DIST geoipupdate-4.9.0-deps.tar.xz 911156 BLAKE2B 136df3a0e94ab0934b48e8860b152edacffae093d26bdbe9593c24f540ce0d6cff215e4cf4ea158bd8dc9a9f3157d5634fea4d66315c5dbc537b42041d0625e6 SHA512 88579ba0e804d7dd9f6cab24d2ac01186f39c47f1ae79d395a77b0725d25e8675928ce34532506f164157cbce4fb2e947efbd2e66c23ed18d61bc67be74ce74d
DIST geoipupdate-4.9.0.tar.gz 36646 BLAKE2B 9eb5e16c39e8c599d3b0fa60804f179d1fb726c44f9f4ed4ed6ff3b853c31c9dece809dcd690e14157f1290c4a9088e696e967f3baeeb7f2762638c70aad6b6a SHA512 29d0639fe636885b1527b4cb795332c103c011d028ada80eb7b07805d91f575554fc0b9fa9a506c644236a2ceab5509f54f0cc1a03a300480350c520484d959c
+DIST geoipupdate-6.0.0-deps.tar.xz 3070844 BLAKE2B 0564c35693e9b38d710dd331abd6ac84a81ee0d916fa7f48eddecb73b07cfdd71b3b502cd9771b67fa16bb92c073deea67981462780b84d051ff7515917de15e SHA512 0b42b95f9ed39db2c18a3b43dfd6a24088e0529e4d8992a8169d16c48e1b1b12ab738d79505ae167a6deef4e979e484e4765a29bfe1db05725aa7e9c598f97ec
+DIST geoipupdate-6.0.0.tar.gz 46523 BLAKE2B ff14026acf39797f69b7cde527c826b78740a65ac4e0914cdffc6276473e3f4367e87e962dfa4634114b7f5b02c33a4a8e675518f4de85238a2342cb367c9f25 SHA512 2b2a6573b6af30ad1ad4c8ed3b97df41bba96212a0e6d90e4a92bd0615f02c9e989168ad56a651d8f35a7d2534e223de5a6f8a34d587f3c8a7a8e19f3b913ca4
diff --git a/net-misc/geoipupdate/files/geoipupdate-6.0.0-use-go-md2man-instead-of-pandoc.patch b/net-misc/geoipupdate/files/geoipupdate-6.0.0-use-go-md2man-instead-of-pandoc.patch
new file mode 100644
index 000000000000..aa48a97ef155
--- /dev/null
+++ b/net-misc/geoipupdate/files/geoipupdate-6.0.0-use-go-md2man-instead-of-pandoc.patch
@@ -0,0 +1,26 @@
+From 250049909d1f9ed3c8ab06e07fcb10487942953a Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Wed, 13 Dec 2023 18:59:31 +0200
+Subject: [PATCH] Use go-md2man instead of perl script with pandoc
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/Makefile
++++ b/Makefile
+@@ -53,10 +53,11 @@ $(BUILDDIR)/GeoIP.conf.md: $(BUILDDIR) doc/GeoIP.conf.md
+ $(BUILDDIR)/geoipupdate.md: $(BUILDDIR) doc/geoipupdate.md
+ sed -e 's|CONFFILE|$(CONFFILE)|g' -e 's|DATADIR|$(DATADIR)|g' -e 's|$$|$(MAYBE_CR)|g' doc/geoipupdate.md > $(BUILDDIR)/geoipupdate.md
+
+-$(BUILDDIR)/GeoIP.conf.5: $(BUILDDIR)/GeoIP.conf.md $(BUILDDIR)/geoipupdate.md
+- dev-bin/make-man-pages.pl "$(BUILDDIR)"
++$(BUILDDIR)/GeoIP.conf.5: %.5 : %.md
++ go-md2man -in $< -out $@
+
+-$(BUILDDIR)/geoipupdate.1: $(BUILDDIR)/GeoIP.conf.5
++$(BUILDDIR)/geoipupdate.1: %.1: %.md
++ go-md2man -in $< -out $@
+
+ clean:
+ rm -rf $(BUILDDIR)/GeoIP.conf \
+--
+2.43.0
+
diff --git a/net-misc/geoipupdate/geoipupdate-6.0.0.ebuild b/net-misc/geoipupdate/geoipupdate-6.0.0.ebuild
new file mode 100644
index 000000000000..eeedc3970bee
--- /dev/null
+++ b/net-misc/geoipupdate/geoipupdate-6.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Performs automatic updates of GeoIP2 and GeoIP Legacy binary databases"
+HOMEPAGE="https://github.com/maxmind/geoipupdate"
+SRC_URI="https://github.com/maxmind/geoipupdate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+BDEPEND="dev-go/go-md2man"
+
+DOCS=( README.md CHANGELOG.md doc/GeoIP.conf.md doc/geoipupdate.md )
+
+PATCHES=(
+ "${FILESDIR}/geoipupdate-6.0.0-use-go-md2man-instead-of-pandoc.patch"
+)
+
+src_compile() {
+ # Do not let these leak from outside into the package
+ unset GOBIN GOPATH GOCODE
+
+ # the horror, the horror ... but it's all automagic
+ export CONFFILE=/etc/GeoIP.conf
+ export DATADIR=/usr/share/GeoIP
+ export VERSION=${PV}
+
+ default
+}
+
+src_install() {
+ dobin build/geoipupdate
+
+ keepdir /usr/share/GeoIP
+
+ insinto /etc
+ doins build/GeoIP.conf
+
+ doman build/GeoIP.conf.5 build/geoipupdate.1
+
+ einstalldocs
+}