summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jupyter_packaging/Manifest1
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.10.4.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index c85c5b7e15f1..a3f61b4140db 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1,2 +1 @@
-DIST jupyter_packaging-0.10.4.tar.gz 21698 BLAKE2B 5490443e197861a53587fe744d749162e412b88bc5c1e5917cd6c145254e4feecbb8b3e3853bf5a3e360fc9ee20c3345af9c7a245aeb1b03639d99d1d69cb377 SHA512 066abaaa00be8154ea39cc3db0bfa4cfe03864c3e50a741f416606c2f8a2d2e0202943f390905ee46f99414168705b9c3519609c6ea16b3b7d54820631c3ba46
DIST jupyter_packaging-0.10.6.tar.gz 21836 BLAKE2B 921e763e11c3973442fa819559d921618aab4010ae7cd4ca3314acb53c7fd7be68f10af46b4d0c9888d2648c0e28565c22ad47270a9d9a1c950640b38a2a1078 SHA512 1b59219dc14c3e44c0f100e9a46b614a8c4395fc26937622515e82f4ffa35c29d8101d6f56a3d496da9279e1e7fc58a91af83bca2b50875afaf1745706ce466d
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.10.4.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.10.4.ebuild
deleted file mode 100644
index 6440233f72bb..000000000000
--- a/dev-python/jupyter_packaging/jupyter_packaging-0.10.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="Tools to help build and install Jupyter Python packages"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomlkit[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- dev-python/deprecation[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # TODO: package "build"
- tests/test_build_api.py::test_build_package
- tests/test_build_api.py::test_deprecated_metadata
-
- # broken by Gentoo pip patch
- # TODO: retry when we finally make the patch less intrusive
- tests/test_datafiles_install.py
- tests/test_install.py
- )
-
- distutils_install_for_testing --via-venv
- epytest ${deselect[@]/#/--deselect }
-}