summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.26.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
index ccf00adbcf2c..ded7a5048924 100644
--- a/sys-apps/system-monitoring-center/Manifest
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -2,3 +2,4 @@ DIST system-monitoring-center-2.21.2.tar.gz 1511509 BLAKE2B 44c573a83cc8eb328854
DIST system-monitoring-center-2.23.0.tar.gz 1753271 BLAKE2B 1426aa8c639f4958ba7e9dbbaba062a1b6768cfe32308888c3d92395a2861b3e3aca7ccd838f89e2c224ea94c6acd9e2c9a904e07e8bc64c31f8d88a2faed7ad SHA512 14347644fe7d5ff112c3b0ad09d394c9c0d70fe75b1fd092d3d4b0e9f6f8de3387c362d546f3272ba645cb9dba9b08089a9361cd7463bd4e3765c9df7338fd17
DIST system-monitoring-center-2.24.0.tar.gz 1756467 BLAKE2B a0a477292b66cdffad5b2909a118381191e605bcf6b633362d4356cba309fbc6836c99ca46e1043c9398d97f85ca2df19afe0b2cede83d5c3bf7adf18fa50700 SHA512 54b80fb91d6845e2d13b42b27ab7c1f1c2379e2ff415f57c81ab1dc82b8e73783cf1aa151a096be5ce810cc001164f18c46e405f7acff318755ec358f7c299d8
DIST system-monitoring-center-2.25.1.tar.gz 1931789 BLAKE2B 27e7901a6d0e505f1c1d4f03655bcf119c624ca1c1cbb2218b7e428bb06f44a8b193febba11da167298c0f92141acf3371232013e14569607be8e0baea72d129 SHA512 57b2daad026ea979e024a795937f0a3f7c553b1690292d82a048d035f56aad50bf8d81fdbca66e2ff11b520ea7c4219754ac5bef0481dcb63b9b7571778a4f0e
+DIST system-monitoring-center-2.26.0.tar.gz 1936049 BLAKE2B 0f8a8472958351e7e4d659aa4d4846fc10455018f16bcf7b3ff11d640984086400a7ebf2deaa6870b92b6f3c5a74a424339279dc8864a8f55f46d16770c6455c SHA512 1303831b2d392dd0454b257f57b493644c2c77fdb800766f44dece748b338b8d25f7f3e4ead46edb84767b1b4d821b69323d6f38668123b05fa2f66f8da0fd40
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.26.0.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.26.0.ebuild
new file mode 100644
index 000000000000..2356432db6ae
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.26.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ sed -i "s|@PYTHON@|${PYTHON}|" "${S}/src/${PN}.in" || die
+
+ default
+}
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}/usr/share/${PN}"
+
+ mv "${ED}/usr/share/appdata" "${ED}/usr/share/metainfo" || die
+}