summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/lean/Manifest1
-rw-r--r--sci-mathematics/lean/lean-3.44.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index 8727c64f6035..88926772a008 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -2,3 +2,4 @@ DIST lean-3.39.1.tar.gz 1878481 BLAKE2B b3d1760594751418d6ebb7754d733e8fdebc5e0e
DIST lean-3.42.0.tar.gz 1908134 BLAKE2B 7b6403786cc1a3a2b974f8df4c2bf2921e4e374ead4290a0e263c8464a9c009fd2f62e7cf5bdbc5087d0c9bb4c57f798b9d1a4b8ee2d66152714ec2af649e196 SHA512 2f1fc1bf3aff7fa806e1cd4647380d6896d98a9191f2035d5a37cc35938de42b243188984aa2fced37bdbee3b2c3c6ef25d27bf2428bf9a0307cc3237c80560f
DIST lean-3.42.1.tar.gz 1908398 BLAKE2B 7a83269deb3dc7ee60bf7a09b36df332355d9caf575b8435345956697121e95e1fb44cada1237e44bab04a56af4fb40c0d01e49f4cb3e4896e616f2bc58bf9ef SHA512 ab266e385e3026ce3219eef6ef171e243576e291fb26cef3d97ca4cc5190988e3bd6fe93c37a1192b8d2eec0ae7620131826ee1073a038f5a024e706953242d1
DIST lean-3.43.0.tar.gz 1909158 BLAKE2B 587995afb123e6c74a730f9709a001bab6b2ac82471dcf8b1219dda782853fcdb9735d16038b95a7950f6530dd3cf1e0b13e4d1044d723d3662217951b809928 SHA512 25cbad94b869bb39edaf9ed2478ffc298b130f22cb4db7c116212546583d670079ddde1b524a33499d00ac43fc82b6928e6801c83d613597aae255db9c45d9f3
+DIST lean-3.44.1.tar.gz 1911708 BLAKE2B 33dc94fb1f1eac2684b7a37fda3545ad6d4f6d703e7914c44b9a05fb57e55d4b9bef484ff1f6608f9bb0fe453ca28b7fa5c74e6bce135df06fb25ad6d9d3a37b SHA512 69ffd1a8519b476dd1879bfe2f8f8f4268a5490f11b581ee1e583382e6f03f947d958e8b5ee8ceead562945a406ee2dc9b0ae2da6f29f03a38828eadab88a4f8
diff --git a/sci-mathematics/lean/lean-3.44.1.ebuild b/sci-mathematics/lean/lean-3.44.1.ebuild
new file mode 100644
index 000000000000..5d8ee8eecd4b
--- /dev/null
+++ b/sci-mathematics/lean/lean-3.44.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CMAKE_IN_SOURCE_BUILD="ON"
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="The Lean Theorem Prover"
+HOMEPAGE="https://leanprover-community.github.io/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
+else
+ SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}/lean-${PV}/src"
+
+LICENSE="Apache-2.0"
+SLOT="0/${MAJOR}"
+IUSE="debug +threads"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-CMakeLists-fix_flags.patch" )
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug; then
+ CMAKE_BUILD_TYPE="Debug"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+
+ local mycmakeargs=(
+ -DALPHA=ON
+ -DAUTO_THREAD_FINALIZATION=ON
+ -DJSON=ON # bug 833900
+ -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
+ -DMULTI_THREAD=$(usex threads)
+ -DUSE_GITHASH=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Disable problematic "style_check" cpplint test,
+ # this also removes the python test dependency
+ --exclude-regex style_check
+ )
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS="You probably want to use lean with mathlib, you can either:
+ - Do not install mathlib globally and use local versions
+ - Use leanproject from sci-mathematics/mathlib-tools
+ $ leanproject global-install
+ - Use leanpkg and compile mathlib (which will take some time)
+ $ leanpkg install https://github.com/leanprover-community/mathlib"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}