summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/civetweb/Manifest1
-rw-r--r--www-servers/civetweb/civetweb-1.11.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/www-servers/civetweb/Manifest b/www-servers/civetweb/Manifest
index b10a725710a2..da62a017d55e 100644
--- a/www-servers/civetweb/Manifest
+++ b/www-servers/civetweb/Manifest
@@ -1,2 +1 @@
-DIST civetweb-1.11.tar.gz 11421650 BLAKE2B 487044a313c2ff005a8dfa247b3d8a3c3b52ef048cbc3050ec8c0402ccef4e12e28de53fed5a3a91df1e7f59ba6c03bf545413ffdd0ce3e4d604148c16c661e9 SHA512 e1520fd2f4a54b6ab4838f4da2ce3f0956e9884059467d196078935a3fce61dad619f3bb1bc2b4c6a757e1a8abfed0e83cba38957c7c52fff235676e9dd1d428
DIST civetweb-1.12.tar.gz 11463079 BLAKE2B 1182f798a2f9cdb34754b3c0edf80160efda31f72d800b26b27ec36ff4a5623745495a52632a128aefda67c6b902250c4e01ec7debd73d4a95abfc42a1b17ea6 SHA512 d6f8d29011bc1accd5384856bef16c0f20305f622a8f8c127cdf3ae5c567db3aba0d76293cc8c77f90f4989c44b2896a45e533d2f2408cc49488d1d234d308f5
diff --git a/www-servers/civetweb/civetweb-1.11.ebuild b/www-servers/civetweb/civetweb-1.11.ebuild
deleted file mode 100644
index b723333e3653..000000000000
--- a/www-servers/civetweb/civetweb-1.11.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-HOMEPAGE="https://github.com/civetweb/civetweb/"
-DESCRIPTION="Embedded C/C++ web server"
-SRC_URI="https://github.com/civetweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cxx +server ssl"
-
-RDEPEND="ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- sed -e 's|DESTINATION lib$|DESTINATION ${CMAKE_INSTALL_LIBDIR}|' \
- -i src/CMakeLists.txt || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=OFF
- -DBUILD_SHARED_LIBS=ON
- -DCIVETWEB_BUILD_TESTING=OFF
- -DCIVETWEB_ENABLE_LUA=OFF
- -DCIVETWEB_ENABLE_DUKTAPE=OFF
- -DCIVETWEB_ENABLE_CXX="$(usex cxx)"
- -DCIVETWEB_ENABLE_SERVER_EXECUTABLE="$(usex server)"
- -DCIVETWEB_ENABLE_SSL="$(usex ssl)"
- )
-
- cmake-utils_src_configure
-}