summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/hexxagon/hexxagon-1.0.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild b/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..b9c29586b33d
--- /dev/null
+++ b/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="Clone of the original DOS game"
+HOMEPAGE="http://www.nesqi.se/"
+SRC_URI="http://www.nesqi.se/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ append-cxxflags -std=c++11
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newicon images/board_N_2.xpm ${PN}.xpm
+ make_desktop_entry ${PN} Hexxagon
+ dodoc README
+}