summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/latexcodec/Manifest1
-rw-r--r--dev-python/latexcodec/latexcodec-2.0.0.ebuild20
-rw-r--r--dev-python/latexcodec/metadata.xml19
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/latexcodec/Manifest b/dev-python/latexcodec/Manifest
new file mode 100644
index 000000000000..cd1b865795d4
--- /dev/null
+++ b/dev-python/latexcodec/Manifest
@@ -0,0 +1 @@
+DIST latexcodec-2.0.0.tar.gz 29919 BLAKE2B 163fe7332aba7628265f1462570c8d22ec4044dd7b7383de8280bbc617ba4dc26e90f12e6777d690c7a8ae4f6564dbf7519bd6f57cf3dca2820a1fc647a1d7ef SHA512 3c0540b4e5dbc88908b26c68b4c6fca573b45a6b17053733b35a16716510bb67ef6099fae8e48e094a6f08be4e4eac48e889366f035ab38f80e31dd61f08a3c1
diff --git a/dev-python/latexcodec/latexcodec-2.0.0.ebuild b/dev-python/latexcodec/latexcodec-2.0.0.ebuild
new file mode 100644
index 000000000000..d3f8bec601bf
--- /dev/null
+++ b/dev-python/latexcodec/latexcodec-2.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lexer and codec to work with LaTeX code in Python"
+HOMEPAGE="https://github.com/mcmtroffaes/latexcodec/ https://pypi.org/project/pybtex/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/latexcodec/metadata.xml b/dev-python/latexcodec/metadata.xml
new file mode 100644
index 000000000000..dda74f681e53
--- /dev/null
+++ b/dev-python/latexcodec/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>william@ewpettersson.se</email>
+ <name>William Pettersson</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy maintainers</name>
+ </maintainer>
+ <longdescription>
+ Latexcodec provides a convenient way of going between text written in LaTeX and unicode. Since it is not a LaTeX compiler, it is more appropriate for short chunks of text, such as a paragraph or the values of a BibTeX entry, and it is not appropriate for a full LaTeX document. In particular, its behavior on the LaTeX commands that do not simply select characters is intended to allow the unicode representation to be understandable by a human reader, but is not canonical and may require hand tuning to produce the desired effect.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">latexcodec</remote-id>
+ <remote-id type="github">mcmtroffaes/latexcodec</remote-id>
+ </upstream>
+</pkgmetadata>