summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyocr/Manifest1
-rw-r--r--dev-python/pyocr/pyocr-0.8.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyocr/Manifest b/dev-python/pyocr/Manifest
index 202c86b8f88f..e45048d36310 100644
--- a/dev-python/pyocr/Manifest
+++ b/dev-python/pyocr/Manifest
@@ -1,2 +1,3 @@
DIST pyocr-0.8.1.tar.gz 67150 BLAKE2B d7f06db3b27c7352365713640c2421e5b73f54869d46c684d6b96d26c3d4c719c5daa1650e023f0cc5a17c0e51b4fb387ef8583ed501ab8369fc70d1c78e77bf SHA512 8a38f8175bd96de152cb0c34640fe0ca0bee369ecc455a1730a47f64d619901e48491fe0cf333073962f28a478f01ec71593881995e956589f60511b8636a32e
+DIST pyocr-0.8.2.tar.gz 67598 BLAKE2B b5cc1338b73f1147195dd094c332836e49189c3fff051de7e634d99de1135b07b1343af3d7c2dcb302e583a0b307c20aa2aaea4e878d6b2325a5aade7e438b23 SHA512 85100aa236bb2c862b5b67137267a657ae88b06eeb9bd1a895c18bfd7318641fa01ea3966499ccdfcc21480522e4996f0e12f2e8931bb455ade3adea428af17d
DIST pyocr-0.8.tar.gz 65454 BLAKE2B 881353eebce22cf316cd4375cc8971e740a9a463216a5b49c07c7813340cfa1a9bdd869b84b4c26566deab1551884179ae2fe0184dec73880b716118367803cd SHA512 c8d811001b460a9004a80fbf570df3fe9a6af11e8ca0e90f23e5f3be54f6a54d859f4ad3db126a5216ea557ecb38ebd5dbece91810df2bf3e95f514c39649bce
diff --git a/dev-python/pyocr/pyocr-0.8.2.ebuild b/dev-python/pyocr/pyocr-0.8.2.ebuild
new file mode 100644
index 000000000000..62e57d8e85b1
--- /dev/null
+++ b/dev-python/pyocr/pyocr-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An optical character recognition (OCR) tool wrapper"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork/pyocr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cuneiform +tesseract"
+REQUIRED_USE="|| ( cuneiform tesseract )"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"
+
+# (tests apparently do not require any backend installed)
+distutils_enable_tests unittest
+
+RDEPEND+="
+ cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )"