summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-block/fio/files/fio-2.2.15-rdma.patch52
-rw-r--r--sys-block/fio/fio-2.15.ebuild2
-rw-r--r--sys-block/fio/fio-2.16.ebuild2
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-block/fio/files/fio-2.2.15-rdma.patch b/sys-block/fio/files/fio-2.2.15-rdma.patch
new file mode 100644
index 000000000000..3ca9198840e4
--- /dev/null
+++ b/sys-block/fio/files/fio-2.2.15-rdma.patch
@@ -0,0 +1,52 @@
+From fd6d9c789bcb8b7c7b1edf34249e034094d341fc Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 28 Feb 2017 22:25:58 -0700
+Subject: [PATCH] configure: add a --disable-rdma flag to control rdma deps
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ configure | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index 15b87fac0e4c..187ac3583805 100755
+--- a/configure
++++ b/configure
+@@ -166,6 +166,8 @@ for opt do
+ ;;
+ --disable-numa) disable_numa="yes"
+ ;;
++ --disable-rdma) disable_rdma="yes"
++ ;;
+ --disable-rbd) disable_rbd="yes"
+ ;;
+ --disable-rbd-blkin) disable_rbd_blkin="yes"
+@@ -204,6 +206,7 @@ if test "$show_help" = "yes" ; then
+ echo "--esx Configure build options for esx"
+ echo "--enable-gfio Enable building of gtk gfio"
+ echo "--disable-numa Disable libnuma even if found"
++ echo "--disable-rdma Disable RDMA support even if found"
+ echo "--disable-gfapi Disable gfapi"
+ echo "--enable-libhdfs Enable hdfs support"
+ echo "--disable-lex Disable use of lex/yacc for math"
+@@ -642,7 +645,7 @@ int main(int argc, char **argv)
+ return 0;
+ }
+ EOF
+-if compile_prog "" "-libverbs" "libverbs" ; then
++if test "$disable_rdma" != "yes" && compile_prog "" "-libverbs" "libverbs" ; then
+ libverbs="yes"
+ LIBS="-libverbs $LIBS"
+ fi
+@@ -660,7 +663,7 @@ int main(int argc, char **argv)
+ return 0;
+ }
+ EOF
+-if compile_prog "" "-lrdmacm" "rdma"; then
++if test "$disable_rdma" != "yes" && compile_prog "" "-lrdmacm" "rdma"; then
+ rdmacm="yes"
+ LIBS="-lrdmacm $LIBS"
+ fi
+--
+2.11.1
+
diff --git a/sys-block/fio/fio-2.15.ebuild b/sys-block/fio/fio-2.15.ebuild
index 1158dbdae902..8080c1b7e603 100644
--- a/sys-block/fio/fio-2.15.ebuild
+++ b/sys-block/fio/fio-2.15.ebuild
@@ -40,6 +40,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
epatch "${FILESDIR}"/fio-2.2.13-libmtd.patch
+ epatch "${FILESDIR}"/fio-2.2.15-rdma.patch #542640
sed -i '/^DEBUGFLAGS/s: -D_FORTIFY_SOURCE=2::g' Makefile || die
epatch_user
@@ -63,6 +64,7 @@ src_configure() {
$(usex gtk '--enable-gfio' '') \
$(usex numa '' '--disable-numa') \
$(usex rbd '' '--disable-rbd') \
+ $(usex rdma '' '--disable-rdma') \
$(usex static '--build-static' '')
echo "$@"
"$@" || die 'configure failed'
diff --git a/sys-block/fio/fio-2.16.ebuild b/sys-block/fio/fio-2.16.ebuild
index c57607e80a28..64a01dc145fb 100644
--- a/sys-block/fio/fio-2.16.ebuild
+++ b/sys-block/fio/fio-2.16.ebuild
@@ -40,6 +40,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/fio-2.2.13-libmtd.patch
+ "${FILESDIR}"/fio-2.2.15-rdma.patch #542640
)
src_prepare() {
@@ -66,6 +67,7 @@ src_configure() {
$(usex gtk '--enable-gfio' '') \
$(usex numa '' '--disable-numa') \
$(usex rbd '' '--disable-rbd') \
+ $(usex rdma '' '--disable-rdma') \
$(usex static '--build-static' '')
echo "$@"
"$@" || die 'configure failed'