summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2022.9.15.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index 2bd6d54a507f..48dd62bdb72f 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
DIST furo-2022.6.21-py3-none-any.whl 323874 BLAKE2B aac38e9aaa8d4fc6fdb00a7da9df8781b18229146970a005077075b0049b6493f280377ed735e9dd5425fdce0c43f8cad5b149957018d9a084ad83c5e5fcabeb SHA512 096c9fd0a18c8c4263607a77703412fcc5d7334b08bb6c448e5369b93572f2176f7fbe3fc7eb0b8c72f09d00eeca379debfec2f6565305d2f5e1bd0518af1558
+DIST furo-2022.9.15-py3-none-any.whl 326084 BLAKE2B 2c0fe323fb35ddc3660dd7d0b2d70bb4ab7dcfabfab894faf93651bf3b34cbd53028bde7f2eb5f9c153db5e3a460fa58df0d69c05c2e059b35dfbeee7ec00adc SHA512 a20c44d0265bd341ff08db5aa158c440b6f0b74d3fb3ef41385da73db2f75373e23f7635b829b9cee037a7f9a4987a09510cbbb328c35abe09d789061e408b2a
diff --git a/dev-python/furo/furo-2022.9.15.ebuild b/dev-python/furo/furo-2022.9.15.ebuild
new file mode 100644
index 000000000000..154f116846f9
--- /dev/null
+++ b/dev-python/furo/furo-2022.9.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}