summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lua/luassert/Manifest1
-rw-r--r--dev-lua/luassert/files/luassert-1.8.0-disable-highlightcolor-test.patch57
-rw-r--r--dev-lua/luassert/luassert-1.8.0-r1.ebuild56
3 files changed, 0 insertions, 114 deletions
diff --git a/dev-lua/luassert/Manifest b/dev-lua/luassert/Manifest
index c111573a5e69..eeadb92638ca 100644
--- a/dev-lua/luassert/Manifest
+++ b/dev-lua/luassert/Manifest
@@ -1,2 +1 @@
-DIST luassert-1.8.0.tar.gz 38874 BLAKE2B ebc4aab1de5dc830d0b9266726ca6bf361e03000f3a8acd27c04805a6c963373755c8e163b187714f64178acc5d755c05493d745b55c785e3254dd41aa4bef31 SHA512 18b296fececa6b0d5950b2a20c4d30da3bbf9b0932c568bbb8ca212b5c82a1047b73c52ee72b4505a41a393d41dd21321189367e038dd029152d177e11bafc93
DIST luassert-1.9.0.tar.gz 42645 BLAKE2B 2541184bb5ee7a6a7e0c8e2fead8c4926a5d8384345dc173d60c9b52bb4cffe9f50e90980293465e1e5cadee337823abf77421d1cfc423eb32d9d73a7594a306 SHA512 267d31f0061376a4766c7e978bda9e4a2396c8bf959d4aaa347ad40bd286a3873441e38983e1e86ea07a1be7cf7c92d91248c4ba70d6dd4ec82f02c7f7638e9f
diff --git a/dev-lua/luassert/files/luassert-1.8.0-disable-highlightcolor-test.patch b/dev-lua/luassert/files/luassert-1.8.0-disable-highlightcolor-test.patch
deleted file mode 100644
index fe3f7815a04e..000000000000
--- a/dev-lua/luassert/files/luassert-1.8.0-disable-highlightcolor-test.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- a/spec/formatters_spec.lua
-+++ b/spec/formatters_spec.lua
-@@ -102,18 +102,6 @@
- assert.is.equal(expected, formatted)
- end)
-
-- it("Checks to see if TableErrorHighlightColor changes error color", function()
-- local ok, colors = pcall(require, "term.colors")
-- if not ok then pending("lua term.colors not available") end
--
-- assert:set_parameter("TableErrorHighlightColor", "red")
-- local t = {1,2,3}
-- local fmtargs = { {crumbs = {2}} }
-- local formatted = assert:format({t, n = 1, fmtargs = fmtargs})[1]
-- local expected = string.format("("..tostring(t)..") {\n [1] = 1\n %s[2] = 2\n [3] = 3 }", colors.red("*"))
-- assert.is.equal(expected, formatted)
-- end)
--
- it("Checks to see if self referencing tables can be formatted", function()
- local t = {1,2}
- t[3] = t
---- a/spec/assertions_spec.lua
-+++ b/spec/assertions_spec.lua
-@@ -472,17 +472,6 @@
- assert.no_error_matches(t_ok, ".*")
- end)
-
-- it("Checks error_matches compares error strings with pattern", function()
-- assert.error_matches(function() error() end, nil)
-- assert.no_error_matches(function() end, nil)
-- assert.does_error_match(function() error(123) end, "^%d+$")
-- assert.error.matches(function() error("string") end, "^%w+$")
-- assert.matches.error(function() error("string") end, "str", nil, true)
-- assert.matches_error(function() error("123string") end, "^[^0-9]+", 4)
-- assert.has_no_error.match(function() error("123string") end, "123", 4, true)
-- assert.does_not.match_error(function() error("string") end, "^%w+$", nil, true)
-- end)
--
- it("Checks error_matches does not compare error objects", function()
- local func = function() end
- assert.no_error_matches(function() error({ "table" }) end, "table")
-@@ -557,15 +546,6 @@
- assert.is_same({}, {assert.has_no_match("%d+", "string", nil, true, "message")})
- end)
-
-- it("Checks assert.has_error returns thrown error on success", function()
-- assert.is_same({"err message", "err message"}, {assert.has_error(function() error("err message") end, "err message")})
-- assert.is_same({"err", "err"}, {assert.has_error(function() error(setmetatable({},{__tostring = function() return "err" end})) end, "err")})
-- assert.is_same({{}, {}}, {assert.has_error(function() error({}) end, {})})
-- assert.is_same({'0', 0}, {assert.has_error(function() error(0) end, 0)})
-- assert.is_same({nil, nil}, {assert.has_error(function() error(nil) end, nil)})
-- assert.is_same({nil, "string"}, {assert.has_no_error(function() end, "string")})
-- end)
--
- it("Checks assert.error_matches returns captures of thrown error on success", function()
- assert.is_same({"err", "message"}, {assert.error_matches(function() error("err message") end, "(err) (%w+)$")})
- assert.is_same({"err"}, {assert.error_matches(function() error(setmetatable({},{__tostring = function() return "err" end})) end, "err", nil, true)})
diff --git a/dev-lua/luassert/luassert-1.8.0-r1.ebuild b/dev-lua/luassert/luassert-1.8.0-r1.ebuild
deleted file mode 100644
index 9310edd6efbd..000000000000
--- a/dev-lua/luassert/luassert-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua
-
-DESCRIPTION="Assertion library for Lua"
-HOMEPAGE="http://olivinelabs.com/busted/"
-SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-lua/say[${LUA_USEDEP}]
- ${LUA_DEPS}
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-1.8.0-disable-highlightcolor-test.patch" )
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto $(lua_get_lmod_dir)/luassert
- doins -r src/.
-
- einstalldocs
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-}