summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-apps/okular/Manifest1
-rw-r--r--kde-apps/okular/files/okular-20.11.90-tests.patch148
-rw-r--r--kde-apps/okular/okular-20.12.0.ebuild107
3 files changed, 256 insertions, 0 deletions
diff --git a/kde-apps/okular/Manifest b/kde-apps/okular/Manifest
index 0408c8c705fc..39e18bf2c398 100644
--- a/kde-apps/okular/Manifest
+++ b/kde-apps/okular/Manifest
@@ -1 +1,2 @@
DIST okular-20.08.3.tar.xz 7520168 BLAKE2B 351a3d786b5451473aa8e9e155cac2a330890fac0acc34e5c897a7faca03844211ab721083408c338df681759f6d5986219395fb54397b185b75512b9f0f618f SHA512 15bbd2fa2f8d836e80f2fa30d0fbcb6e7303ee2bfb12ebc305ec7b51f046cc0f66a3abeb94458e60f1b17dce7cc964d679d038207766c2d941a238a32b663573
+DIST okular-20.12.0.tar.xz 7882588 BLAKE2B ecc6ed748bb39b15f150ab0ec6ff45929f47427a4af9493fe86486ee31d608ad5252e05f2c8ec3be5aa6d5c99d72108c710920cdebcd5833b718b90172cc9989 SHA512 d61a3126b1b288a3b82edbd405db144a1f40748d1d2ee338da98549588c1234ada2a5b41c3788480a214d1d4b310657dcb49413c893e4060533c3edb8d800b64
diff --git a/kde-apps/okular/files/okular-20.11.90-tests.patch b/kde-apps/okular/files/okular-20.11.90-tests.patch
new file mode 100644
index 000000000000..633513bd2af3
--- /dev/null
+++ b/kde-apps/okular/files/okular-20.11.90-tests.patch
@@ -0,0 +1,148 @@
+From d9cdea559ffa730fd3592b78f5f8530da3d4c803 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu, 12 Oct 2017 14:09:09 +0200
+Subject: [PATCH] Move tests into existing (auto)tests subdirectories
+
+---
+ generators/chm/CMakeLists.txt | 12 +++---------
+ generators/chm/autotests/CMakeLists.txt | 8 ++++++++
+ generators/chm/autotests/chmgeneratortest.cpp | 2 +-
+ generators/comicbook/CMakeLists.txt | 10 +++-------
+ generators/comicbook/autotests/CMakeLists.txt | 6 ++++++
+ generators/kimgio/CMakeLists.txt | 6 +-----
+ generators/kimgio/tests/CMakeLists.txt | 5 +++++
+ generators/kimgio/tests/kimgiotest.cpp | 2 +-
+ 8 files changed, 28 insertions(+), 23 deletions(-)
+ create mode 100644 generators/chm/autotests/CMakeLists.txt
+ create mode 100644 generators/comicbook/autotests/CMakeLists.txt
+ create mode 100644 generators/kimgio/tests/CMakeLists.txt
+
+diff --git a/generators/chm/CMakeLists.txt b/generators/chm/CMakeLists.txt
+index 9d82b9394..b3a33afe4 100644
+--- a/generators/chm/CMakeLists.txt
++++ b/generators/chm/CMakeLists.txt
+@@ -30,15 +30,9 @@ set(okularGenerator_chmlib_SRCS
+ okular_add_generator(okularGenerator_chmlib ${okularGenerator_chmlib_SRCS})
+ target_link_libraries(okularGenerator_chmlib okularcore ${CHM_LIBRARY} ${LIBZIP_LIBRARY} KF5::KHtml)
+
+-########### autotests ###############
+-
+-add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
+-ecm_add_test(autotests/chmgeneratortest.cpp
+- TEST_NAME "chmgeneratortest"
+- LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore
+-)
+-
+-target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
++if(BUILD_TESTING)
++ add_subdirectory(autotests)
++endif()
+
+ ########### install files ###############
+ install( FILES okularChm.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
+diff --git a/generators/chm/autotests/CMakeLists.txt b/generators/chm/autotests/CMakeLists.txt
+new file mode 100644
+index 000000000..59753ca45
+--- /dev/null
++++ b/generators/chm/autotests/CMakeLists.txt
+@@ -0,0 +1,8 @@
++add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
++
++ecm_add_test(chmgeneratortest.cpp
++ TEST_NAME "chmgeneratortest"
++ LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore
++)
++
++target_compile_definitions(chmgeneratortest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_chmlib>")
+diff --git a/generators/chm/autotests/chmgeneratortest.cpp b/generators/chm/autotests/chmgeneratortest.cpp
+index 18305913e..b28822d68 100644
+--- a/generators/chm/autotests/chmgeneratortest.cpp
++++ b/generators/chm/autotests/chmgeneratortest.cpp
+@@ -32,7 +32,7 @@ void ChmGeneratorTest::initTestCase()
+ {
+ Okular::SettingsCore::instance(QStringLiteral("ChmGeneratorTest"));
+ m_document = new Okular::Document(nullptr);
+- const QString testFile = QStringLiteral(KDESRCDIR "autotests/data/test.chm");
++ const QString testFile = QStringLiteral(KDESRCDIR "data/test.chm");
+ QMimeDatabase db;
+ const QMimeType mime = db.mimeTypeForFile(testFile);
+ QCOMPARE(m_document->openDocument(testFile, QUrl(), mime), Okular::Document::OpenSuccess);
+diff --git a/generators/comicbook/CMakeLists.txt b/generators/comicbook/CMakeLists.txt
+index 9a07c7183..316c93152 100644
+--- a/generators/comicbook/CMakeLists.txt
++++ b/generators/comicbook/CMakeLists.txt
+@@ -29,13 +29,9 @@ if (KArchive_HAVE_LZMA)
+ target_compile_definitions(okular_comicbook PRIVATE -DWITH_K7ZIP=1)
+ endif()
+
+-########### autotests ###############
+-
+-add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
+-ecm_add_test(autotests/comicbooktest.cpp
+- TEST_NAME "comicbooktest"
+- LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore okular_comicbook
+-)
++if(BUILD_TESTING)
++ add_subdirectory(autotests)
++endif()
+
+ ########### install files ###############
+ install( FILES okularComicbook.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
+diff --git a/generators/comicbook/autotests/CMakeLists.txt b/generators/comicbook/autotests/CMakeLists.txt
+new file mode 100644
+index 000000000..aaacb341a
+--- /dev/null
++++ b/generators/comicbook/autotests/CMakeLists.txt
+@@ -0,0 +1,6 @@
++add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
++
++ecm_add_test(comicbooktest.cpp
++ TEST_NAME "comicbooktest"
++ LINK_LIBRARIES Qt5::Test KF5::CoreAddons okularcore okular_comicbook
++)
+diff --git a/generators/kimgio/CMakeLists.txt b/generators/kimgio/CMakeLists.txt
+index db14d741f..49f893bc1 100644
+--- a/generators/kimgio/CMakeLists.txt
++++ b/generators/kimgio/CMakeLists.txt
+@@ -13,13 +13,9 @@ okular_add_generator(okularGenerator_kimgio generator_kimgio.cpp)
+ target_link_libraries(okularGenerator_kimgio okularcore KF5::KExiv2 KF5::I18n)
+
+ if(BUILD_TESTING)
+- add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/" )
+- set( kimgiotest_SRCS tests/kimgiotest.cpp ${CMAKE_SOURCE_DIR}/part/pagepainter.cpp ${CMAKE_SOURCE_DIR}/part/guiutils.cpp ${CMAKE_SOURCE_DIR}/part/debug_ui.cpp )
+- ecm_add_test(${kimgiotest_SRCS} TEST_NAME "kimgiotest" LINK_LIBRARIES okularcore okularpart Qt5::Svg Qt5::Test)
+- target_compile_definitions(kimgiotest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_kimgio>")
++ add_subdirectory(tests)
+ endif()
+
+-
+ ########### install files ###############
+ install( FILES okularKimgio.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR} )
+ install( PROGRAMS okularApplication_kimgio.desktop org.kde.mobile.okular_kimgio.desktop DESTINATION ${KDE_INSTALL_APPDIR} )
+diff --git a/generators/kimgio/tests/CMakeLists.txt b/generators/kimgio/tests/CMakeLists.txt
+new file mode 100644
+index 000000000..844c9096a
+--- /dev/null
++++ b/generators/kimgio/tests/CMakeLists.txt
+@@ -0,0 +1,5 @@
++add_definitions( -DKDESRCDIR="${CMAKE_CURRENT_SOURCE_DIR}/../" )
++
++set( kimgiotest_SRCS kimgiotest.cpp ${CMAKE_SOURCE_DIR}/part/pagepainter.cpp ${CMAKE_SOURCE_DIR}/part/guiutils.cpp ${CMAKE_SOURCE_DIR}/part/debug_ui.cpp )
++ecm_add_test(${kimgiotest_SRCS} TEST_NAME "kimgiotest" LINK_LIBRARIES okularcore okularpart Qt5::Svg Qt5::Test)
++target_compile_definitions(kimgiotest PRIVATE -DGENERATOR_PATH="$<TARGET_FILE:okularGenerator_kimgio>")
+diff --git a/generators/kimgio/tests/kimgiotest.cpp b/generators/kimgio/tests/kimgiotest.cpp
+index 2b507ed79..acd70b168 100644
+--- a/generators/kimgio/tests/kimgiotest.cpp
++++ b/generators/kimgio/tests/kimgiotest.cpp
+@@ -7,7 +7,7 @@
+ * (at your option) any later version. *
+ ***************************************************************************/
+
+-#include "../../settings_core.h"
++#include "../../../settings_core.h"
+ #include "../generator_kimgio.h"
+
+ #include <core/observer.h>
+--
+2.29.2
+
diff --git a/kde-apps/okular/okular-20.12.0.ebuild b/kde-apps/okular/okular-20.12.0.ebuild
new file mode 100644
index 000000000000..7891e55760d8
--- /dev/null
+++ b/kde-apps/okular/okular-20.12.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.75.0
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Universal document viewer based on KDE Frameworks"
+HOMEPAGE="https://okular.kde.org https://apps.kde.org/en/okular"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="chm djvu epub +image-backend markdown mobi +pdf +plucker +postscript qml share speech +tiff"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjs-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kpty-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/threadweaver-${KFMIN}:5
+ media-libs/freetype
+ >=media-libs/phonon-4.11.0
+ sys-libs/zlib
+ chm? (
+ dev-libs/chmlib
+ dev-libs/libzip:=
+ >=kde-frameworks/khtml-${KFMIN}:5
+ )
+ djvu? ( app-text/djvu )
+ epub? ( app-text/ebook-tools )
+ image-backend? (
+ >=dev-qt/qtgui-${QTMIN}:5[gif,jpeg,png]
+ >=kde-apps/libkexiv2-${PVCUT}:5
+ )
+ markdown? ( app-text/discount )
+ mobi? ( >=kde-apps/kdegraphics-mobipocket-${PVCUT}:5 )
+ pdf? ( app-text/poppler[qt5] )
+ plucker? ( virtual/jpeg:0 )
+ postscript? ( app-text/libspectre )
+ share? ( >=kde-frameworks/purpose-${KFMIN}:5 )
+ speech? ( >=dev-qt/qtspeech-${QTMIN}:5 )
+ tiff? ( media-libs/tiff:0 )
+"
+RDEPEND="${DEPEND}
+ image-backend? ( >=kde-frameworks/kimageformats-${KFMIN}:5 )
+ qml? (
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20.11.90-tests.patch" # bug 734138
+ "${FILESDIR}/${PN}-20.08.2-hide-mobile-app.patch" # avoid same-name entry
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DOKULAR_UI=$(usex qml "both" "desktop")
+ $(cmake_use_find_package chm CHM)
+ $(cmake_use_find_package chm KF5KHtml)
+ $(cmake_use_find_package chm LibZip)
+ $(cmake_use_find_package djvu DjVuLibre)
+ $(cmake_use_find_package epub EPub)
+ $(cmake_use_find_package image-backend KF5KExiv2)
+ $(cmake_use_find_package markdown Discount)
+ $(cmake_use_find_package mobi QMobipocket)
+ $(cmake_use_find_package pdf Poppler)
+ $(cmake_use_find_package plucker JPEG)
+ $(cmake_use_find_package postscript LibSpectre)
+ $(cmake_use_find_package share KF5Purpose)
+ $(cmake_use_find_package speech Qt5TextToSpeech)
+ $(cmake_use_find_package tiff TIFF)
+ )
+ ecm_src_configure
+}
+
+src_test() {
+ # mainshelltest hangs, chmgeneratortest fails, bug #603116
+ # parttest hangs, bug #641728, annotationtoolbartest fails, KDE-Bug #429640
+ local myctestargs=(
+ -E "(mainshelltest|chmgeneratortest|parttest|annotationtoolbartest)"
+ )
+
+ ecm_src_test
+}