summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/libecpint/Manifest1
-rw-r--r--sci-libs/libecpint/libecpint-1.0.6.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/libecpint/Manifest b/sci-libs/libecpint/Manifest
index 0371440420bf..3c042087a64b 100644
--- a/sci-libs/libecpint/Manifest
+++ b/sci-libs/libecpint/Manifest
@@ -1 +1,2 @@
DIST libecpint-1.0.5.tar.gz 1313876 BLAKE2B 279618262bc32928964d559bda3f2d6235340bf807abb755c676a20ea6712d36d80a84a2522dd16d19290f5d622e47c4c0a34b549ffdb628f6c07372a5109981 SHA512 ad68599c1a220556ebb265968da6701596cf2388aa422100b80863bd8f73eaa1be5a2349c0db8c8864c3c8cf57151fe3d4520a3670f3b40ce147195079886d86
+DIST libecpint-1.0.6.tar.gz 1331016 BLAKE2B 9b1a8452b6810eaca17eb9e6efe876537ae32e980593ec89681fa4b2d6eaf5a908d5971c774eccd75858025599eeeb119a74b03fdbf7bcee644316dc6acad0d9 SHA512 8b0bf20d263891255ea8828cb9df7c919155ef461a66ae6c8979e9996e3392ea1b7adf21ef9ad9188e2f56547c1e2b525c3711f7cd1ace2b3c09b8ae38f75ee8
diff --git a/sci-libs/libecpint/libecpint-1.0.6.ebuild b/sci-libs/libecpint/libecpint-1.0.6.ebuild
new file mode 100644
index 000000000000..47004ee7019c
--- /dev/null
+++ b/sci-libs/libecpint/libecpint-1.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Efficient evaluation of integrals over ab initio effective core potentials"
+HOMEPAGE="https://github.com/robashaw/libecpint"
+SRC_URI="https://github.com/robashaw/libecpint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/pugixml"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBECPINT_BUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}