summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/uucp/Manifest1
-rw-r--r--dev-ml/uucp/uucp-14.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/uucp/Manifest b/dev-ml/uucp/Manifest
index 08d06a8a8e95..783aec0484d8 100644
--- a/dev-ml/uucp/Manifest
+++ b/dev-ml/uucp/Manifest
@@ -1 +1,2 @@
DIST uucp-13.0.0.tbz 466488 BLAKE2B 90b62446ed069f95b0ca8bbad8273b215f0a66f6a3d19639d60a73f440268e9274d4e98e7ac8a534bbb6a34ab485e989432894f22f2f5c1303ca49f828efe859 SHA512 24d0fc75ba337115fd6445d3c3dfa60fe5f6920b227cd8360cd60ad51b652ccc2129a47f195f7559d99635367e64855343dc03de1109987f296a280e0fefff4d
+DIST uucp-14.0.0.tbz 476162 BLAKE2B 1c75b7bf98858bc60dee12bebfa99556afd6b344b65b12a4eafcbd39c57e2359f1a47aa0f28c5450f078db95d78ab545eecf84d0d5dbadb2bf1705c17e7179a4 SHA512 2d0224aed5d5accbb121624898f08598e8c74a2415942f159a54221c0cdac62ed64fc70a039c833e50110cefce77754ada9ac2d58f79a6fc9331135326fe6899
diff --git a/dev-ml/uucp/uucp-14.0.0.ebuild b/dev-ml/uucp/uucp-14.0.0.ebuild
new file mode 100644
index 000000000000..ec89c6b0ae38
--- /dev/null
+++ b/dev-ml/uucp/uucp-14.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode character properties for OCaml"
+HOMEPAGE="https://erratique.ch/software/uucp https://github.com/dbuenzli/uucp"
+SRC_URI="https://erratique.ch/software/uucp/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-ml/topkg
+ dev-ml/findlib"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/ocamlbuild"
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-uutf true \
+ --with-uunf false \
+ --with-cmdliner true \
+ || die
+}