summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/mistletoe/Manifest1
-rw-r--r--dev-python/mistletoe/metadata.xml12
-rw-r--r--dev-python/mistletoe/mistletoe-1.1.0.ebuild26
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/mistletoe/Manifest b/dev-python/mistletoe/Manifest
new file mode 100644
index 000000000000..d17c4b4fefaa
--- /dev/null
+++ b/dev-python/mistletoe/Manifest
@@ -0,0 +1 @@
+DIST mistletoe-1.1.0.gh.tar.gz 116246 BLAKE2B 52761841380f28e490f1d675ab95bf0f31be44c909c5221dadca37eaeb3bc909c4d9091d52bd3a99f9b4b371fa102cf0f02225a1aa0732ccda4dca2ab85214e2 SHA512 3b1d8b6a9e3fc1fa67a212977a1c26cedafdf2bd2cc53113b8bb583433e69af0b4fd47b575f9a1ba4bda50b1c55a0d27faf9877b6300982eee2f6b8fcb621b7c
diff --git a/dev-python/mistletoe/metadata.xml b/dev-python/mistletoe/metadata.xml
new file mode 100644
index 000000000000..64caa5b341e4
--- /dev/null
+++ b/dev-python/mistletoe/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">miyuchina/mistletoe</remote-id>
+ <remote-id type="pypi">mistletoe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mistletoe/mistletoe-1.1.0.ebuild b/dev-python/mistletoe/mistletoe-1.1.0.ebuild
new file mode 100644
index 000000000000..924f2c3cc893
--- /dev/null
+++ b/dev-python/mistletoe/mistletoe-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fast, extensible Markdown parser in pure Python"
+HOMEPAGE="
+ https://github.com/miyuchina/mistletoe/
+ https://pypi.org/project/mistletoe/
+"
+# pypi has incomplete test suite
+SRC_URI="
+ https://github.com/miyuchina/mistletoe/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest