summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/patchelf/Manifest1
-rw-r--r--dev-util/patchelf/patchelf-0.17.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
index 7e7fcf5bffb8..ed30350914d1 100644
--- a/dev-util/patchelf/Manifest
+++ b/dev-util/patchelf/Manifest
@@ -1 +1,2 @@
+DIST patchelf-0.17.2.tar.gz 143954 BLAKE2B 7ed684c63955a0b9cfe293fb966f7f08a90c76e8efb2b493eaf3705c57767b31b31e48ab59f39ff1d91b7a4501e6d203e32a40040625a44a7d44113b1320530c SHA512 e5545416d32248d023759457d0a5cd4841d69f39366eb0aa9cfd8a43d2ce372c6e05995bf60ba62bd85c6d98fdece2dbd1e20872e338ef5ac75f11b82ae091b3
DIST patchelf-0.18.0.tar.gz 331312 BLAKE2B e6ce4ec3bd89c280bb37230dbeb566b803f09900006e79f7dba74f138f66e17746d331baea4def6a43163024b3d86aa8dbac9b2c6545ac146298a8b84373d03b SHA512 6a917d7336b1e8c59f42d4cd1dc725df1378d77657fce13cb31547da1d4805b9df8a834a7b8408fda8aa1dbeb37d0cdca74d8698844ea2f44149f800b802dea6
diff --git a/dev-util/patchelf/patchelf-0.17.2.ebuild b/dev-util/patchelf/patchelf-0.17.2.ebuild
new file mode 100644
index 000000000000..ef24854c8688
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.17.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}