summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/goland/Manifest3
-rw-r--r--dev-util/goland/goland-2017.3.ebuild45
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-util/goland/Manifest b/dev-util/goland/Manifest
index 5e080e854f34..a854d3b51bae 100644
--- a/dev-util/goland/Manifest
+++ b/dev-util/goland/Manifest
@@ -1 +1,2 @@
-DIST goland-173.3531.21.tar.gz 213040527 SHA256 5738129cb5ab81428cf6fa0ec18e97221b1303d966e679e575a0ac8e669170cd SHA512 db2deb4e52fb4135e3fb27c63a181c34acddf61dd2bedf81e50144a85b3e9bcb1a7490532b6841815e2b888c660aa26bc8c3176f83bb30bcf20ec568cdfeb65b WHIRLPOOL 51502c1d35a582601378a6ed403c4c84d36418a340f00479180143a1eddcae05832242f9bb075ebb63c906c5f0385a5ef53a32b4d2975669a8b54266b9778e8c
+DIST goland-173.3531.21.tar.gz 213040527 BLAKE2B 57fbc0820fb09aa23ebad45c9f6477469f71f84d3abb9e77eba45a90c89695754a7800ff768b63b815b48a1aa35631af0332a0a9af10b3e6dc6d22c587aef30c SHA512 db2deb4e52fb4135e3fb27c63a181c34acddf61dd2bedf81e50144a85b3e9bcb1a7490532b6841815e2b888c660aa26bc8c3176f83bb30bcf20ec568cdfeb65b
+DIST goland-2017.3.tar.gz 213261483 BLAKE2B 4c84d073265fc701dc0f34571850c2fab05e2e07479d9dc886af660a097a361a5532cf9078569e9dc8cee0322f92544683e9c05689d025bb39de925a10e05c2d SHA512 5fa8d61850e31c1db82e32d9ccccaad71fc00db85a31bc423384b443819d9dc6f3ba11399c580d8eb9c3fe698b437c13072fc49126359bd405b7d57e12c92328
diff --git a/dev-util/goland/goland-2017.3.ebuild b/dev-util/goland/goland-2017.3.ebuild
new file mode 100644
index 000000000000..3698daaba68c
--- /dev/null
+++ b/dev-util/goland/goland-2017.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+SLOT=0
+
+SRC_URI="http://download.jetbrains.com/go/${P}.tar.gz"
+DESCRIPTION="Golang IDE by JetBrains"
+HOMEPAGE="http://www.jetbrains.com/go"
+
+KEYWORDS="~amd64"
+LICENSE="IDEA
+ || ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
+
+QA_PREBUILT="opt/${P}/*"
+
+S=${WORKDIR}/GoLand-${PV}
+
+RDEPEND="dev-lang/go"
+
+src_prepare() {
+ default
+ if ! use arm; then
+ rm -rf bin/fsnotifier-arm || die
+ fi
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{${PN}.sh,fsnotifier{,64}}
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.png" "${PN}.png"
+ make_desktop_entry "${PN}" "gogland" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+}