summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pmw/Manifest1
-rw-r--r--dev-python/pmw/pmw-2.0.1-r3.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pmw/Manifest b/dev-python/pmw/Manifest
index db7c6f3cc171..0e1ba494fa74 100644
--- a/dev-python/pmw/Manifest
+++ b/dev-python/pmw/Manifest
@@ -1,2 +1 @@
-DIST Pmw-2.0.1.tar.gz 830448 BLAKE2B c78fef1570a34b9784f936f16856c4450164d8a232770e59cc084c1113888af8ee002cd1c7ddeadcddaacb5eae9ff58fcbfc270fc066875523e31a9d26770cd3 SHA512 99654e961aa40a64eebc08fe473e94da0ce431e6465255c68c251dfd544a51edef1a5d97dfd89ce756eb5f7fcf917dbef27f646ba9451ab72f3d460daa09a556
DIST Pmw-2.1.1.tar.gz 1077119 BLAKE2B 3e78796489d996df8fbcaca119f03b718f5457d38af175232c055c1c94e6c98c3f198e3dd0859a4af1cc88f36df83ed57c0d8ee67f90362a8590de5a37d2f669 SHA512 7f4c3181b0ae546f9f89cf666917fd9ea0161a2c4a4e6b5756e0aeb543fcd3ed4598c83e294b04312fea6a386b06b370668b4400f1497cc8b2fc2ab19a3fdd3d
diff --git a/dev-python/pmw/pmw-2.0.1-r3.ebuild b/dev-python/pmw/pmw-2.0.1-r3.ebuild
deleted file mode 100644
index 0873e357ce2a..000000000000
--- a/dev-python/pmw/pmw-2.0.1-r3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="tk"
-
-inherit distutils-r1 virtualx pypi
-
-DESCRIPTION="Toolkit for building high-level compound Python widgets using the Tkinter module"
-HOMEPAGE="http://pmw.sourceforge.net/"
-
-LICENSE="BSD"
-SLOT="py3"
-KEYWORDS="~alpha amd64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc test"
-# https://sourceforge.net/p/pmw/bugs/39/
-RESTRICT="test"
-
-DEPEND="!dev-python/pmw:0"
-RDEPEND="${DEPEND}"
-
-python_test() {
- VIRTUALX_COMMAND="${PYTHON}"
- cd "${BUILD_DIR}/lib/Pmw/Pmw_${PV//./_}/" || die
- cp tests/{flagup.bmp,earthris.gif} . || die
- for test in tests/*_test.py; do
- echo "running test "$test
- PYTHONPATH=tests:../../ virtx emake -j1 $test || die
- done
-}
-
-python_install_all() {
- local DIR="Pmw/Pmw_${PV//./_}"
-
- use doc && HTML_DOCS=( "${DIR}"/doc/. )
-
- distutils-r1_python_install_all
-}