summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/yatex/Manifest1
-rw-r--r--app-emacs/yatex/files/yatex-1.82-texinfo.patch22
-rw-r--r--app-emacs/yatex/yatex-1.82.ebuild58
3 files changed, 81 insertions, 0 deletions
diff --git a/app-emacs/yatex/Manifest b/app-emacs/yatex/Manifest
index 7ff4894c24f5..475ff65ae333 100644
--- a/app-emacs/yatex/Manifest
+++ b/app-emacs/yatex/Manifest
@@ -1 +1,2 @@
DIST yatex1.80.tar.gz 376944 BLAKE2B 355726fb3b38bfbc314647739d4af6e588848b5ade208fe1e026106a7cc2c220edcf10214f37ee7c9cc461ecb3e776c3969e329d5a331b3d8ce9f669f2361e26 SHA512 6548d1ac95ce95198468698d9b91449736e4be8af15d29352c00f7604fd7b34b2c606afb2d90d1115fd64dc859efdd9c993a6b3733f9321ca7671615977b4bd5
+DIST yatex1.82.tar.gz 387358 BLAKE2B 77c88563e3beb7b29ac8a4d7204d14b966c9a88b1c2f04c6160089f0b61a70c9d6aa135d2e1cee6e13a90cc108428ce80e7ef0d0b8852b9a8651e67f34af7e1e SHA512 8c2890fc12e93aace5ac51e24da315a9d241aec023a3c67187c1fd28d2a7a02d1688b7e1177e1ba13411ecb394b5d581298c735cd80195e663bbdcf240f10fe5
diff --git a/app-emacs/yatex/files/yatex-1.82-texinfo.patch b/app-emacs/yatex/files/yatex-1.82-texinfo.patch
new file mode 100644
index 000000000000..1938b1a766d2
--- /dev/null
+++ b/app-emacs/yatex/files/yatex-1.82-texinfo.patch
@@ -0,0 +1,22 @@
+--- yatex1.82/docs/yatexe.tex
++++ yatex1.82/docs/yatexe.tex
+@@ -382,7 +382,7 @@
+ @section Special Filtering Region
+ A region like below will be passed to external filter command.
+ @example
+-%#BEGIN FILTER{foo.pdf}{dot -T %t -o %o}
++%#BEGIN FILTER@{foo.pdf@}@{dot -T %t -o %o@}
+ \if0
+ ....blah blah blah...
+ ....blah blah blah...
+--- yatex1.82/docs/yatexj.tex
++++ yatex1.82/docs/yatexj.tex
+@@ -488,7 +488,7 @@
+ ます。そのためには以下のようなソースを文書中に書きます。
+
+ @example
+-%#BEGIN FILTER{foo.pdf}{blockdiag -T %t -o %o}
++%#BEGIN FILTER@{foo.pdf@}@{blockdiag -T %t -o %o@}
+ \if0
+ ---
+ ....blah blah blah...
diff --git a/app-emacs/yatex/yatex-1.82.ebuild b/app-emacs/yatex/yatex-1.82.ebuild
new file mode 100644
index 000000000000..bdf92dd93aab
--- /dev/null
+++ b/app-emacs/yatex/yatex-1.82.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Yet Another TeX mode for Emacs"
+HOMEPAGE="http://www.yatex.org/"
+SRC_URI="http://www.${PN}.org/${P/-}.tar.gz"
+S="${WORKDIR}/${P/-}"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="l10n_ja"
+
+BDEPEND="l10n_ja? ( virtual/libiconv )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.76-direntry.patch
+ "${FILESDIR}"/${PN}-1.80-texinfo-5.patch
+ "${FILESDIR}"/${P}-texinfo.patch
+)
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "/(help-dir/,/)))/c\ (help-dir \"${SITEETC}/${PN}\"))" ${PN}hlp.el
+
+ elisp_src_prepare
+}
+
+src_compile() {
+ cd docs
+ makeinfo {${PN},yahtml}e.tex || die
+
+ if use l10n_ja; then
+ iconv -f WINDOWS-31J -t UTF-8 ${PN}j.tex > ${PN}-ja.texi || die
+ iconv -f WINDOWS-31J -t UTF-8 yahtmlj.tex > yahtml-ja.texi || die
+ makeinfo {${PN},yahtml}-ja.texi || die
+ fi
+}
+
+src_install() {
+ elisp-install ${PN} *.el
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+
+ insinto ${SITEETC}/${PN}
+ doins help/YATEXHLP.eng
+ doinfo docs/{${PN},yahtml}.info*
+ dodoc install docs/*.eng
+
+ if use l10n_ja; then
+ doins help/YATEXHLP.jp
+ doinfo docs/{${PN},yahtml}-ja.info*
+ dodoc 00readme ${PN}.new docs/{htmlqa,qanda,*.doc}
+ fi
+}