summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/cob/cob-0.9-r1.ebuild27
-rw-r--r--games-arcade/cob/files/cob-0.9-gcc43.patch8
-rw-r--r--games-arcade/cob/files/cob-0.9-gcc44.patch12
3 files changed, 37 insertions, 10 deletions
diff --git a/games-arcade/cob/cob-0.9-r1.ebuild b/games-arcade/cob/cob-0.9-r1.ebuild
new file mode 100644
index 000000000000..26d73169d352
--- /dev/null
+++ b/games-arcade/cob/cob-0.9-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Cruising on Broadway: a painting-type game"
+HOMEPAGE="http://www.autismuk.freeserve.co.uk/"
+SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[joystick,sound,video]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_install() {
+ default
+ make_desktop_entry ${PN} "Cruising on Broadway"
+}
diff --git a/games-arcade/cob/files/cob-0.9-gcc43.patch b/games-arcade/cob/files/cob-0.9-gcc43.patch
index 6b1f574628df..bc7e6fb3e02c 100644
--- a/games-arcade/cob/files/cob-0.9-gcc43.patch
+++ b/games-arcade/cob/files/cob-0.9-gcc43.patch
@@ -1,5 +1,5 @@
---- cob/menu.cpp
-+++ cob/menu.cpp
+--- a/cob/menu.cpp
++++ b/cob/menu.cpp
@@ -16,6 +16,7 @@
***************************************************************************/
@@ -8,8 +8,8 @@
// **************************************************************************************************************************
//
---- cob/sdw.hxx
-+++ cob/sdw.hxx
+--- a/cob/sdw.hxx
++++ b/cob/sdw.hxx
@@ -19,6 +19,7 @@
#include <iostream>
diff --git a/games-arcade/cob/files/cob-0.9-gcc44.patch b/games-arcade/cob/files/cob-0.9-gcc44.patch
index dd90b388e6d8..02b4842617f2 100644
--- a/games-arcade/cob/files/cob-0.9-gcc44.patch
+++ b/games-arcade/cob/files/cob-0.9-gcc44.patch
@@ -1,5 +1,5 @@
---- cob/game.cpp
-+++ cob/game.cpp
+--- a/cob/game.cpp
++++ b/cob/game.cpp
@@ -15,6 +15,7 @@
* *
***************************************************************************/
@@ -8,8 +8,8 @@
#include "cob.hxx"
// **************************************************************************************************************************
---- cob/main.cpp
-+++ cob/main.cpp
+--- a/cob/main.cpp
++++ b/cob/main.cpp
@@ -15,6 +15,7 @@
* *
***************************************************************************/
@@ -18,8 +18,8 @@
#include "cob.hxx"
// **************************************************************************************************************************
---- cob/map.cpp
-+++ cob/map.cpp
+--- a/cob/map.cpp
++++ b/cob/map.cpp
@@ -15,6 +15,7 @@
* *
***************************************************************************/