summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.3.1.ebuild2
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch37
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild b/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild
index f6f494b3507f..bfaf4b447d3d 100644
--- a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild
@@ -48,6 +48,8 @@ DEPEND="${RDEPEND}
sys-devel/flex
virtual/yacc"
+PATCHES=( "${FILESDIR}"/${P}-libressl.patch )
+
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
cmake_src_prepare
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch
new file mode 100644
index 000000000000..ed5a49ce4361
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-libressl.patch
@@ -0,0 +1,37 @@
+From b2f7634c9dbc0ef68640f0571787d92300e9f9f9 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <stefan@steils.org>
+Date: Sat, 15 Aug 2020 07:18:31 +0300
+Subject: [PATCH] ec_sslwrap: fix compilation with LibreSSL
+
+Disable taking over SNI extension from ClientHello and SSL configuration
+operations until LibreSSL supports the required API.
+
+Fixes: https://github.com/Ettercap/ettercap/issues/1068
+Upstream-Status: Submitted
+[https://github.com/Ettercap/ettercap/pull/1069]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ src/ec_sslwrap.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ec_sslwrap.c b/src/ec_sslwrap.c
+index b9f26a14..1e4c24fc 100644
+--- a/src/ec_sslwrap.c
++++ b/src/ec_sslwrap.c
+@@ -71,11 +71,11 @@
+ #define TLS_server_method SSLv23_server_method
+ #endif
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
++#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
+ #define HAVE_OPENSSL_1_1_0
+ #endif
+
+-#if (OPENSSL_VERSION_NUMBER >= 0x10101000L)
++#if (OPENSSL_VERSION_NUMBER >= 0x10101000L) && !defined(LIBRESSL_VERSION_NUMBER)
+ #define HAVE_OPENSSL_1_1_1
+ #endif
+
+--
+2.28.0
+