summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.24.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index e7a3ee682189..be689110c4e8 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-kde-5.23.5.tar.xz 89520 BLAKE2B 6ec2b844f64c2e099120ec17e23c42db6b55f40fae4992c9a02cd815bc78337f76209c821980141d7bfd19135058caeefe313fa37ae236865d5f134af3750b47 SHA512 7481be6c3a5adb42e3a9b2c03533de9e956e188f3ce5edd349a65a8d65dd690f5292cdc8431dee71bee089ef8c5a30b5c18925e61658facf6dfed1d332bdaf6e
DIST xdg-desktop-portal-kde-5.24.3.tar.xz 88424 BLAKE2B a235ae6b87ee7269533650a95f94468ceeb8c094b565389d5c79a0b7a6c6ff00b9c4c6c2c05a976099f55e5ca4835cca0f719bad622e7febcc878e9e1223c48f SHA512 685fb8165740b94c68015ee47aec7e407e0da476bb61b306b0ace91a9c7b794afc6bc46ea38bf19ccfaab3ef5d016ddad58ff1a4783f43b5157e42317046a7a2
+DIST xdg-desktop-portal-kde-5.24.4.tar.xz 88540 BLAKE2B 6a6522bbfe99919a98ee697fc6331fe6b833f376307dbfec303dddb2020c97d355dcd0b251d0feb1e270f2b9a7633f8e770f5e58d9a0ade618dd376fc3890eed SHA512 6efd6452aff8e139921d884e272d26421ed3b1b83c36ca1bdee8bb54633cf85866be87e5f169ececd5364d901d78d9f4b0dd520450b890540a5bd514b0e2e54c
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.24.4.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.24.4.ebuild
new file mode 100644
index 000000000000..daaa5a417460
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.24.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.90.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5[cups]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.1.1
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ || (
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ <dev-qt/qtwayland-5.15.3:5
+ )
+"