summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/cdw/cdw-0.8.1-r1.ebuild11
-rw-r--r--app-cdr/cdw/cdw-9999.ebuild7
-rw-r--r--app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch26
3 files changed, 40 insertions, 4 deletions
diff --git a/app-cdr/cdw/cdw-0.8.1-r1.ebuild b/app-cdr/cdw/cdw-0.8.1-r1.ebuild
index 2e0b7596745d..c524d89d06de 100644
--- a/app-cdr/cdw/cdw-0.8.1-r1.ebuild
+++ b/app-cdr/cdw/cdw-0.8.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="An ncurses based console frontend for cdrtools and dvd+rw-tools"
HOMEPAGE="http://cdw.sourceforge.net"
@@ -22,8 +22,15 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/${PN}-0.8.1-fix-ar-call.patch" )
+
DOCS=( AUTHORS ChangeLog NEWS README THANKS cdw.conf )
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
}
diff --git a/app-cdr/cdw/cdw-9999.ebuild b/app-cdr/cdw/cdw-9999.ebuild
index 5013ebb9082d..f23f85b84c76 100644
--- a/app-cdr/cdw/cdw-9999.ebuild
+++ b/app-cdr/cdw/cdw-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,6 @@ HOMEPAGE="http://cdw.sourceforge.net"
LICENSE="GPL-2+"
SLOT="0"
-DOCS=( AUTHORS ChangeLog NEWS README THANKS cdw.conf )
RDEPEND="
app-cdr/dvd+rw-tools
@@ -27,6 +26,10 @@ BDEPEND="virtual/pkgconfig"
S=${WORKDIR}/${ECVS_MODULE}
+PATCHES=( "${FILESDIR}/${PN}-0.8.1-fix-ar-call.patch" )
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS cdw.conf )
+
src_prepare() {
default
eautoreconf
diff --git a/app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch b/app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch
new file mode 100644
index 000000000000..a578696c1c82
--- /dev/null
+++ b/app-cdr/cdw/files/cdw-0.8.1-fix-ar-call.patch
@@ -0,0 +1,26 @@
+diff --git a/configure.ac b/configure.ac
+index 76627c7..527e2cb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -119,7 +119,7 @@ AC_TYPE_UINT16_T
+ AC_TYPE_UINT32_T
+ AC_TYPE_UINT8_T
+ AC_CHECK_TYPES([ptrdiff_t])
+-
++AC_CHECK_TOOL(AR, ar, false)
+
+
+
+diff --git a/src/user_interface/Makefile.in b/src/user_interface/Makefile.in
+index 5d5f1fc..4d8214b 100644
+--- a/src/user_interface/Makefile.in
++++ b/src/user_interface/Makefile.in
+@@ -88,7 +88,7 @@ CONFIG_HEADER = $(top_builddir)/config_cdw.h
+ CONFIG_CLEAN_FILES =
+ CONFIG_CLEAN_VPATH_FILES =
+ LIBRARIES = $(noinst_LIBRARIES)
+-AR = ar
++AR = @AR@
+ ARFLAGS = cru
+ AM_V_AR = $(am__v_AR_@AM_V@)
+ am__v_AR_ = $(am__v_AR_@AM_DEFAULT_V@)