summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/mistune/Manifest1
-rw-r--r--dev-python/mistune/mistune-2.0.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/mistune/Manifest b/dev-python/mistune/Manifest
index 8cd631310112..6d4612e7afbf 100644
--- a/dev-python/mistune/Manifest
+++ b/dev-python/mistune/Manifest
@@ -1 +1,2 @@
DIST mistune-0.8.4.tar.gz 58322 BLAKE2B e65d45c5c95706a49a7fd407afe5f10e82a475766ca272ec3bebba8c89e670fe6efced7b09537efb69d3fd36e75091e370170a15ad7488b5cbe9186e2ccaf4db SHA512 36c3ef5d5537f5cceaa43e4da20a84b27c378cb744a93f0380024faefde490bcb42c453f79002ca049083fc437278f4afb3e10de5462f9eeb9077ca2a2fcaea7
+DIST mistune-2.0.0.tar.gz 75635 BLAKE2B 0704b5043178c553961bfd5d99ea92ee097849e6a4cc6196c7e97e0caa4560541b4ae4b9e61e62e21592be6f2f0c142081200c5a398e68d7b7f7d54f0bbade15 SHA512 cdb1ad001a95680b048f4363e95c00e4d597007fc2ae72adeca483ffed3fae3aa55c7774d96a1dd7400568b24c73cc6f877bb7b0f63b48689a97a1e4ce0b1c5d
diff --git a/dev-python/mistune/mistune-2.0.0.ebuild b/dev-python/mistune/mistune-2.0.0.ebuild
new file mode 100644
index 000000000000..ca582a8ab68a
--- /dev/null
+++ b/dev-python/mistune/mistune-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.org/project/mistune/ https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # seriously?
+ echo 'build-backend = "setuptools.build_meta"' >> pyproject.toml || die
+ distutils-r1_src_prepare
+}