summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/olsrd/olsrd-0.9.6.1.ebuild10
-rw-r--r--net-misc/olsrd/olsrd-0.9.8.ebuild13
2 files changed, 18 insertions, 5 deletions
diff --git a/net-misc/olsrd/olsrd-0.9.6.1.ebuild b/net-misc/olsrd/olsrd-0.9.6.1.ebuild
index 39becf0aefee..8e8f409db132 100644
--- a/net-misc/olsrd/olsrd-0.9.6.1.ebuild
+++ b/net-misc/olsrd/olsrd-0.9.6.1.ebuild
@@ -2,16 +2,18 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils multilib toolchain-funcs versionator
+
+inherit toolchain-funcs versionator
DESCRIPTION="An implementation of the Optimized Link State Routing protocol"
HOMEPAGE="http://www.olsr.org/"
SRC_URI="http://www.olsr.org/releases/$(get_version_component_range 1-2)/${P}.tar.bz2"
-SLOT="0"
LICENSE="BSD LGPL-2.1"
+SLOT="0"
KEYWORDS="amd64 x86"
IUSE="gtk pud"
+
DEPEND="
virtual/pkgconfig
gtk? (
@@ -24,10 +26,12 @@ DEPEND="
RDEPEND="
${DEPEND}
"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0.2-gtk.patch
"${FILESDIR}"/${PN}-0.9.6-gpsd.patch
)
+
src_prepare() {
default
@@ -64,6 +68,7 @@ src_compile() {
OLSRD_LDFLAGS="${LDFLAGS}" \
OS=linux \
build_all
+
if use gtk; then
emake -C gui/linux-gtk LIBDIR="/usr/$(get_libdir)/${PN}" CC="$(tc-getCC)"
fi
@@ -72,6 +77,7 @@ src_compile() {
src_install() {
emake OS=linux LIBDIR="${D}/usr/$(get_libdir)/${PN}" \
DESTDIR="${D}" STRIP=true install_all
+
if use gtk; then
emake -C gui/linux-gtk \
LIBDIR="${D}/usr/$(get_libdir)/${PN}" DESTDIR="${D}" install
diff --git a/net-misc/olsrd/olsrd-0.9.8.ebuild b/net-misc/olsrd/olsrd-0.9.8.ebuild
index 8eaf17bbb898..bede675037e3 100644
--- a/net-misc/olsrd/olsrd-0.9.8.ebuild
+++ b/net-misc/olsrd/olsrd-0.9.8.ebuild
@@ -2,18 +2,19 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib toolchain-funcs
+
+inherit toolchain-funcs
DESCRIPTION="An implementation of the Optimized Link State Routing protocol"
HOMEPAGE="http://www.olsr.org/"
SRC_URI="https://github.com/OLSR/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SLOT="0"
LICENSE="BSD LGPL-2.1"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk pud"
+
DEPEND="
- virtual/pkgconfig
gtk? (
dev-libs/glib:2
x11-libs/gdk-pixbuf:2
@@ -24,10 +25,13 @@ DEPEND="
RDEPEND="
${DEPEND}
"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0.2-gtk.patch
"${FILESDIR}"/${PN}-0.9.6-gpsd.patch
)
+
src_prepare() {
default
@@ -57,6 +61,7 @@ src_configure() {
src_compile() {
tc-export PKG_CONFIG
+
emake \
CC="$(tc-getCC)" \
LIBDIR="/usr/$(get_libdir)/${PN}" \
@@ -64,6 +69,7 @@ src_compile() {
OS=linux \
VERBOSE=1 \
build_all
+
if use gtk; then
emake -C gui/linux-gtk LIBDIR="/usr/$(get_libdir)/${PN}" CC="$(tc-getCC)"
fi
@@ -77,6 +83,7 @@ src_install() {
OS=linux \
STRIP=true \
install_all
+
if use gtk; then
emake -C gui/linux-gtk \
DESTDIR="${D}" \