summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.9.3-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.9.3-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.9.3-r1.ebuild
index 1b4e768f10d3..4196d5868457 100644
--- a/net-analyzer/fail2ban/fail2ban-0.9.3-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.9.3-r1.ebuild
@@ -35,7 +35,8 @@ DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
src_prepare() {
# Replace /var/run with /run, but not in the top source directory
- sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -mindepth 2 -type f ) || die
+ find . -mindepth 2 -type f -exec \
+ sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
# Fix bashisms and do not direct useful output to /dev/null (bug #536320)
# Remove global logrotate settings (bug #549856)
@@ -47,13 +48,13 @@ src_prepare() {
}
python_test() {
- ${EPYTHON} bin/${PN}-testcases
+ "${PYTHON}" "bin/${PN}-testcases" || die "tests failed with ${EPYTHON}"
}
src_install() {
distutils-r1_src_install
- rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run
+ rm -r "${D}"/usr/share/doc/${PN} "${D}"/run || die
# not FILESDIR
newconfd files/gentoo-confd ${PN}
@@ -96,7 +97,6 @@ pkg_postinst() {
elog "If you want to use ${PN}'s persistent database, then reinstall"
elog "dev-lang/python with USE=sqlite"
fi
-
if has_version sys-apps/systemd[-python]; then
elog "If you want to track logins through sys-apps/systemd's"
elog "journal backend, then reinstall sys-apps/systemd with USE=python"