summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/liquid_feedback_core/Manifest1
-rw-r--r--www-apps/liquid_feedback_core/files/liquid_feedback_core-4.0.0-gentoo.patch51
-rw-r--r--www-apps/liquid_feedback_core/liquid_feedback_core-4.0.0.ebuild43
3 files changed, 95 insertions, 0 deletions
diff --git a/www-apps/liquid_feedback_core/Manifest b/www-apps/liquid_feedback_core/Manifest
index 11e79310b42a..9da9f60aed94 100644
--- a/www-apps/liquid_feedback_core/Manifest
+++ b/www-apps/liquid_feedback_core/Manifest
@@ -1,3 +1,4 @@
DIST liquid_feedback_core-v2.2.6.tar.gz 127440 BLAKE2B d62ecd8c9947259a7213f92ecaf1491a5e858ff2fdaff5e020fc4ec0c433297d8a7701a812de200130a1ed7f08ded1d9f31d42de7fffa2981361efee0e31646c SHA512 6f680398a7d2e529e642dc94ba16bc1b33d25459ddbf629c06387391ef13c0e212a108cc337cd2bc29505f4f6436b6e92994e63eaa09fe1c07733d2821d9b7f1
DIST liquid_feedback_core-v3.0.4.tar.gz 142983 BLAKE2B 05e8c1630a8fa3932b4fc291843dd0c45e2333940394a0632309c9041dc850cc894a6cb54fb840329f67812ebcde5d540c338cf27a88ad428aaa066329725409 SHA512 baea8a61c94e640557d0169b6171247ff0303ff1a9c8b587c6769e367cf56805c1a1e660aadf7178d984182be6dde326770240b3ffeda42139c4a94445a2bbf8
DIST liquid_feedback_core-v3.2.2.tar.gz 162505 BLAKE2B dc6e9d0b8d1e596150520e068e7743a6e839f7e6ffc3c605d090973a179652858c037c4f12c75774d158adfc60484d1ac321350fa7f8d16329043051ae2cd98c SHA512 60a3548008235822e83c6614e990d87200b342d8e5c5fd1ca1f6092bc48d918f9dbfcc130039f4acf2956a19100cc96187ac1c7f5174f7e69a45f651643ab1d9
+DIST liquid_feedback_core-v4.0.0.tar.gz 194817 BLAKE2B d33c4f60371050664e19425b3e344435c2b35d7e48fa682b9857d0bbc22032e59f4811ce41b8cad2f8d325e26a9adbd573bf205289b6f419c32829392014cbdf SHA512 499a60d4d71e85357ffe45fe0cbcd13bdf131f80c2b24e320b06646e56c7cd422e44306132d7fbe3dc22bf1be9af208ef9bfa143142cd2aa0880382dfe874aa4
diff --git a/www-apps/liquid_feedback_core/files/liquid_feedback_core-4.0.0-gentoo.patch b/www-apps/liquid_feedback_core/files/liquid_feedback_core-4.0.0-gentoo.patch
new file mode 100644
index 000000000000..cb57a08870ec
--- /dev/null
+++ b/www-apps/liquid_feedback_core/files/liquid_feedback_core-4.0.0-gentoo.patch
@@ -0,0 +1,51 @@
+--- a/lf_update_issue_order.c 2021-04-10 18:32:19.101947834 +0200
++++ b/lf_update_issue_order.c 2021-04-10 18:36:07.377117090 +0200
+@@ -1,3 +1,5 @@
++#define _GNU_SOURCE
++
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -417,7 +419,7 @@
+ logging = 1;
+ }
+ for (i=argb; i<argc; i++) len += strlen(argv[i]) + 1;
+- conninfo = malloc(len * sizeof(char));
++ conninfo = malloc(len * sizeof(char) + 1);
+ if (!conninfo) {
+ fprintf(stderr, "Error: Could not allocate memory for conninfo string.\n");
+ abort();
+--- a/lf_update_suggestion_order.c 2021-04-10 18:38:31.138743181 +0200
++++ b/lf_update_suggestion_order.c 2021-04-10 18:39:29.851786017 +0200
+@@ -1,3 +1,5 @@
++#define _GNU_SOURCE
++
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -474,7 +476,7 @@
+ logging = 1;
+ }
+ for (i=argb; i<argc; i++) len += strlen(argv[i]) + 1;
+- conninfo = malloc(len * sizeof(char));
++ conninfo = malloc(len * sizeof(char) + 1);
+ if (!conninfo) {
+ fprintf(stderr, "Error: Could not allocate memory for conninfo string.\n");
+ abort();
+--- a/lf_update.c 2021-04-10 18:40:48.036510216 +0200
++++ b/lf_update.c 2021-04-10 18:55:46.869758233 +0200
+@@ -1,3 +1,5 @@
++#define _GNU_SOURCE
++
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -78,7 +78,7 @@
+ }
+ len += seglen;
+ }
+- conninfo = malloc(len * sizeof(char));
++ conninfo = malloc(len * sizeof(char) + 1);
+ if (!conninfo) {
+ fprintf(stderr, "Error: Could not allocate memory for conninfo string\n");
+ return 1;
diff --git a/www-apps/liquid_feedback_core/liquid_feedback_core-4.0.0.ebuild b/www-apps/liquid_feedback_core/liquid_feedback_core-4.0.0.ebuild
new file mode 100644
index 000000000000..d80161e4dd89
--- /dev/null
+++ b/www-apps/liquid_feedback_core/liquid_feedback_core-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Internet platforms for proposition development and decision making"
+HOMEPAGE="https://www.public-software-group.org/liquid_feedback"
+SRC_URI="https://www.public-software-group.org/pub/projects/liquid_feedback/backend/v${PV}/${MY_P}.tar.gz
+ https://dev.gentoo.org/~tupone/distfiles/${MY_P}.tar.gz"
+
+LICENSE="HPND CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-db/postgresql:="
+RDEPEND="${DEPEND}
+ dev-db/pgLatLon"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.4-gentoo.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="-I $(pg_config --includedir)" \
+ LDFLAGS="${LDFLAGS} -L $(pg_config --libdir)"
+}
+
+src_install() {
+ dobin lf_update lf_update_suggestion_order lf_export
+ insinto /usr/share/${PN}
+ doins -r {core,init,demo,test}.sql update
+ dodoc README "${FILESDIR}"/postinstall-en.txt
+}