summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Sereal-Encoder/Sereal-Encoder-4.23.0-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Sereal-Encoder/Sereal-Encoder-4.23.0-r1.ebuild b/dev-perl/Sereal-Encoder/Sereal-Encoder-4.23.0-r1.ebuild
new file mode 100644
index 000000000000..4000313c09b4
--- /dev/null
+++ b/dev-perl/Sereal-Encoder/Sereal-Encoder-4.23.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=YVES
+DIST_VERSION=4.023
+inherit edo perl-module toolchain-funcs
+
+DESCRIPTION="Fast, compact, powerful binary serialization"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Note: bundled zstd fails compile
+RDEPEND="
+ virtual/perl-XSLoader
+ app-arch/csnappy:=
+ app-arch/zstd:=
+ >=dev-libs/miniz-2.2.0-r1:=
+"
+DEPEND="
+ app-arch/csnappy:=
+ app-arch/zstd:=
+ >=dev-libs/miniz-2.2.0-r1:=
+"
+# Tester note: ideally you want dev-perl/Sereal-Decoder
+# as well, but we can't depend on it because it forms
+# a tight cycle if we do
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-7.0.0
+ >=virtual/perl-ExtUtils-ParseXS-2.210.0
+ virtual/perl-File-Path
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Test-Deep
+ dev-perl/Test-Differences
+ dev-perl/Test-LongString
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warn
+ )
+"
+
+src_prepare() {
+ local bundled_lib
+ for bundled_lib in inc/Devel snappy miniz{.c,.h} zstd ; do
+ edo rm -r ${bundled_lib}
+ done
+
+ sed -i -e "/miniz.*OBJ_EXT/d" inc/Sereal/BuildTools.pm || die
+
+ perl-module_src_prepare
+}
+
+src_compile() {
+ DIST_MAKE=(
+ "INC=$($(tc-getPKG_CONFIG) --cflags miniz)"
+ "OTHERLDFLAGS=$($(tc-getPKG_CONFIG) --libs miniz)"
+ )
+
+ perl-module_src_compile
+}