summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/croc/Manifest2
-rw-r--r--net-misc/croc/croc-9.6.9.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index 57cf1d583c51..63520fadfe5d 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -1,2 +1,4 @@
DIST croc-9.6.6-vendor.tar.xz 972376 BLAKE2B ad1f77ef5d26ace05edffd3628da3c1ab393549d17761c70c3302e35179587097657a1d1e82f9be1732fb5d7df9a2f0eac6e003c43b0767d56662d87a5159d51 SHA512 53fc2af249ff62b702587bd89155c5432415dc6d8d8643453cb6d17f46b74cf669ecc7f06a5f64da459c690858126202be365d25ec31e73840621de2bf68faba
DIST croc-9.6.6.tar.gz 511129 BLAKE2B 550228f7911ffbeac656fe7930f879db7ab8630e52acbd8a859a14219673937f2994d3fd02e42999754e5a701b9b3296ab7907c231fac2e4a37c51588b864190 SHA512 0e3dec57d0d1337c9f45c81fa71f6d9673cc76f5c53ae9b0068f9e388788c433debebb536a43ec578b58e80b9da482949ff16cc63a883b8085fbec54a932bde2
+DIST croc-9.6.9-vendor.tar.xz 974884 BLAKE2B d6d061fd8259126dc107de3efcae3a023c9a8db44ba96343350360c6d321d73720d1079d46927f65d9ea1001e6421751241d2fe1c04a4f450ff3c4dadc5c6be1 SHA512 2f4ab17ae0c00bc1ac097aeda9fc791b98d8cf6ad31644bdf600a4c321894dea9974155950723e9d19b15c011eef81ab27dae1b2bc2eb4517611bac77bde590f
+DIST croc-9.6.9.tar.gz 512036 BLAKE2B cdd18f9b4460905742d31852ceafda19a3e9c57ef33e6b2e0a21105da9b7d0cac1dfca50f6b217d76be6368d6fb26b540709c165b5b9781ca8952003811e83ad SHA512 5abd9eac5ffd4fae711f8169c4344aa6b61647309aa74267b1442b94d3a9d7ea11962b993862e00c7df8a23a260c20c643d468930836df71995652a5abf8772b
diff --git a/net-misc/croc/croc-9.6.9.ebuild b/net-misc/croc/croc-9.6.9.ebuild
new file mode 100644
index 000000000000..d49781a4bf65
--- /dev/null
+++ b/net-misc/croc/croc-9.6.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+SRC_URI="https://github.com/schollz/croc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-vendor.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -work ./...
+}