summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/lockrun/lockrun-20120508-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/lockrun/lockrun-20120508-r2.ebuild b/dev-util/lockrun/lockrun-20120508-r2.ebuild
new file mode 100644
index 000000000000..b102465e2395
--- /dev/null
+++ b/dev-util/lockrun/lockrun-20120508-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lockrun - runs cronjobs with overrun protection"
+HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+src_unpack() {
+ cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/${PN}.c || die
+ cp -v "${FILESDIR}"/${PN}.c-${PV} "${S}"/README || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" ${PN}
+ sed -i README -e '60q;s|^ \*||g' || die
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}