summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-6.7.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index c0bf989b7731..f6a2dab0b3ec 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -4,3 +4,4 @@ DIST qtwayland-everywhere-opensource-src-5.15.12.tar.xz 569180 BLAKE2B 456b02d06
DIST qtwayland-everywhere-opensource-src-5.15.13.tar.xz 569152 BLAKE2B 9e6ceb514b17ba7fa99d6263d5c84edf0f39c510a080bf607ba1e68dfacc2f0f509529d5e4fd61e04ed04a922c5f82b6a5aabbf5d78e487ca5c1cc1c86d13e19 SHA512 1f5b5e911ad9026d08260e5ce15aad5c9167726ce42db85634392f1e49d545ca5bcd4e44304f1ff633ffe110712a2b5dad87de6cd89eb3b7e6c657fe260e388d
DIST qtwayland-everywhere-src-6.6.2.tar.xz 1118996 BLAKE2B db54b7708f01a7e4e59561eb209d9c0cd79400ec477603d826061f3c2cf6683dccbbb48e73dc7b5ebe674ef7c5b438fd75eccbd4bab9191219598f526e6b395f SHA512 ed5539ac9515ba93822ee1dfdedd3ece46a51c50b23efd0fb90ead2728b651c41bec42a6e2e2caf72bda0f274940e9f00049bae42c1315e0226e4a42c708f664
DIST qtwayland-everywhere-src-6.6.3.tar.xz 1120056 BLAKE2B e5bbdd53f0c133dcd310c5e85480abf28d005291996e1f9414292eeeab144e8a7706bdbe0ca41fd3bfb8d4a36020fe6075102a9e94bad0a85ae338497c6e69d1 SHA512 6829c9aef2b7fc37a6a94c0093d478c13742d8c2b3d2b9444b7a1dbe022bfce1f6a5665d16bebe221e93bddd964b726451b2949352877b25d65654df17a58eb1
+DIST qtwayland-everywhere-src-6.7.0.tar.xz 1121748 BLAKE2B d42003056236b542a95484157bee3bf74a602882ac79dde02c74f762e3c07eec28405534df46cf5d4b8381d0f99cccfeeca10f614622bbb7b09ec81dbb6a06aa SHA512 cda0e0736f85656d05b2399970413ffc5082af4256c8b3087c3f1d06cad5ef5ad7cb8838513723569193df02cd3c3df3d5478d99464606c62c42629ef75c225f
diff --git a/dev-qt/qtwayland/qtwayland-6.7.0.ebuild b/dev-qt/qtwayland/qtwayland-6.7.0.ebuild
new file mode 100644
index 000000000000..dc3ce8575fd3
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-6.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="accessibility compositor qml vulkan"
+
+RDEPEND="
+ dev-libs/wayland
+ ~dev-qt/qtbase-${PV}:6[accessibility=,gui,opengl,vulkan=,wayland]
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+ compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+"
+BDEPEND="dev-util/wayland-scanner"
+
+CMAKE_SKIP_TESTS=(
+ # segfaults for not-looked-into reasons, but not considered
+ # an issue given >=seatv5 exists since wayland-1.10 (2016)
+ tst_seatv4
+ # needs a compositor/opengl, skip the extra trouble
+ tst_surface
+ tst_xdgdecorationv1
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Quick)
+ $(qt_feature compositor wayland_server)
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # users' session setting may break tst_clientextension (bug #927030)
+ unset DESKTOP_SESSION XDG_CURRENT_DESKTOP
+ unset GNOME_DESKTOP_SESSION_ID KDE_FULL_SESSION
+
+ qt6-build_src_test
+}