summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r1.ebuild b/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..f924f90e41a2
--- /dev/null
+++ b/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Generating CHAP packets"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RDEPEND="dev-lang/php:*[crypt,hash]"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/Crypt
+ doins CHAP.php
+}
+
+src_test() {
+ pear run-tests tests/Crypt_CHAP.phpt || die
+}